Project

General

Profile

Bug #61957

test_client_limits.TestClientLimits.test_client_release_bug fails

Added by Rishabh Dave 8 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Tags:
Backport:
reef,quincy,pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2023-07-06T20:48:49.614 INFO:tasks.cephfs_test_runner:test_client_release_bug (tasks.cephfs.test_client_limits.TestClientLimits) ... ERROR
2023-07-06T20:48:49.615 INFO:tasks.cephfs_test_runner:
2023-07-06T20:48:49.615 INFO:tasks.cephfs_test_runner:======================================================================
2023-07-06T20:48:49.616 INFO:tasks.cephfs_test_runner:ERROR: test_client_release_bug (tasks.cephfs.test_client_limits.TestClientLimits)
2023-07-06T20:48:49.616 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-06T20:48:49.617 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2023-07-06T20:48:49.617 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_79365bb3b803780276d69efb2cc4afe5b160de9e/qa/tasks/cephfs/test_client_limits.py", line 208, in test_client_release_bug
2023-07-06T20:48:49.618 INFO:tasks.cephfs_test_runner:    self.wait_for_health("MDS_CLIENT_LATE_RELEASE", session_timeout + 10)
2023-07-06T20:48:49.618 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_79365bb3b803780276d69efb2cc4afe5b160de9e/qa/tasks/ceph_test_case.py", line 184, in wait_for_health
2023-07-06T20:48:49.619 INFO:tasks.cephfs_test_runner:    self.wait_until_true(seen_health_warning, timeout)
2023-07-06T20:48:49.619 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_79365bb3b803780276d69efb2cc4afe5b160de9e/qa/tasks/ceph_test_case.py", line 231, in wait_until_true
2023-07-06T20:48:49.619 INFO:tasks.cephfs_test_runner:    raise TestTimeoutError("Timed out after {0}s and {1} retries".format(elapsed, retry_count))
2023-07-06T20:48:49.620 INFO:tasks.cephfs_test_runner:tasks.ceph_test_case.TestTimeoutError: Timed out after 70s and 0 retries
2023-07-06T20:48:49.620 INFO:tasks.cephfs_test_runner:
2023-07-06T20:48:49.621 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2023-07-06T20:48:49.622 INFO:tasks.cephfs_test_runner:Ran 9 tests in 720.134s

This failure is not related to any of the PRs that were under testing because it could reproduced for the testing branch when it contained all PRs, no PRs as well as when it contained any one of the PRs that were under testing.
https://pulpito.ceph.com/rishabh-2023-07-05_22:21:20-fs-wip-rishabh-2023Jul5-testing-default-smithi/7327895
https://pulpito.ceph.com/rishabh-2023-07-06_19:33:28-fs-wip-rishabh-2023Jul5-testing-default-smithi/7328188
https://pulpito.ceph.com/rishabh-2023-07-08_07:00:50-fs-wip-rishabh-readdir-testing-default-smithi/7329037
https://pulpito.ceph.com/rishabh-2023-07-08_07:01:39-fs-wip-rishabh-slow-op-testing-default-smithi/7329055
https://pulpito.ceph.com/rishabh-2023-07-08_12:15:41-fs-wip-rishabh-mdscaps-2-testing-default-smithi/7329073
https://pulpito.ceph.com/rishabh-2023-07-08_13:58:23-fs-wip-rishabh-2023Jul5-base-4-testing-default-smithi/7329118

And this issue is new because it doesn't occur on older branches -
https://pulpito.ceph.com/rishabh-2023-07-07_17:52:00-fs-wip-rishabh-mdscaps-testing-default-smithi/7328419/

History

#1 Updated by Venky Shankar 7 months ago

  • Category set to Correctness/Safety
  • Assignee set to Venky Shankar
  • Target version set to v19.0.0
  • Backport set to reef,quincy,pacific

#2 Updated by Xiubo Li 7 months ago

Venky, this seems the same issue with https://tracker.ceph.com/issues/62229 and I have one PR to fix it.

[EDIT] Sorry I didn't notice this existing one.

#3 Updated by Venky Shankar 7 months ago

  • Status changed from New to Duplicate

Xiubo Li wrote:

Venky, this seems the same issue with https://tracker.ceph.com/issues/62229 and I have one PR to fix it.

[EDIT] Sorry I didn't notice this existing one.

yes - its a duplicate. Thanks for noticing.

Also available in: Atom PDF