Project

General

Profile

Bug #5780

the size of the old acting set should be compared with the min_size of the old osdmap

Added by Loic Dachary about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
-
Start date:
07/28/2013
Due date:
% Done:

100%

Spent time:
Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

work in progress

pg_interval_t::check_new_interval compares min_size of the new osdmap with the size of the old acting set

It should compare with the old osdmap.

Associated revisions

Revision ee9f04c5 (diff)
Added by Loic Dachary about 6 years ago

check_new_interval must compare old acting with old osdmap

When trying to establish if the old acting set is either empty or
smaller than the min_size of the osdmap,
pg_interval_t::check_new_interval compares with the min_size of the
new osdmap. Since the goal is to try to determine if the previous
interval may have been writeable, it should not enter the if when
there were not enough osds in the acting set ( i.e. < min_size ). But
it may enter it anyway if min_size was decremented in the new osdmap.

A complete set of unit tests were added to cover the logic of
check_new_interval. The parameters are prepared to describe a
situation where the function returns false (i.e. no new
interval). Each case is described in a separate bloc that introduces
the minimal changes to demonstrate the intended test case.

Because a number of cases have the same output while implementing a
different logic, the debug output is parsed to differentiate between them.

A test case demonstrating the problem ( check_new_interval must
compare old acting with old osdmap ) is added, with a link to the bug
number for future reference. The problem is fixed. The text of two
debug messages are slightly changed to make the maintenance of the
test that match them easier.

http://tracker.ceph.com/issues/5780 refs #5780

Signed-off-by: Loic Dachary <>
Reviewed-by: Sage Weil <>
Reviewed-by: Samuel Just <>

History

#1 Updated by Loic Dachary about 6 years ago

  • Description updated (diff)
  • Status changed from In Progress to Need Review

#2 Updated by Ian Colle about 6 years ago

  • Assignee changed from Loic Dachary to Samuel Just

Sam - please review

#3 Updated by Loic Dachary about 6 years ago

  • Status changed from Need Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF