Project

General

Profile

Actions

Bug #56652

closed

cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway Timeout

Added by Laura Flores over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
backport_processed
Backport:
quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

/a/yuriw-2022-07-19_23:25:12-rados-wip-yuri2-testing-2022-07-15-0755-pacific-distro-default-smithi/6938938

2022-07-20T05:37:10.294 INFO:tasks.workunit.client.0.smithi116.stderr:cephadm ['-v', 'add-repo', '--dev', 'master']
2022-07-20T05:37:10.294 INFO:tasks.workunit.client.0.smithi116.stderr:Fetching repo metadata from shaman and chacra...
2022-07-20T05:37:10.440 INFO:tasks.workunit.client.0.smithi116.stderr:repository not found in shaman (might not be available yet)
2022-07-20T05:37:10.478 INFO:tasks.workunit.client.0.smithi116.stderr:Traceback (most recent call last):
2022-07-20T05:37:10.479 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephadm/../../../src/cephadm/cephadm", line 6572, in query_shaman
2022-07-20T05:37:10.479 INFO:tasks.workunit.client.0.smithi116.stderr:    shaman_response = urlopen(shaman_url)
2022-07-20T05:37:10.479 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 223, in urlopen
2022-07-20T05:37:10.479 INFO:tasks.workunit.client.0.smithi116.stderr:    return opener.open(url, data, timeout)
2022-07-20T05:37:10.480 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 532, in open
2022-07-20T05:37:10.480 INFO:tasks.workunit.client.0.smithi116.stderr:    response = meth(req, response)
2022-07-20T05:37:10.480 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 642, in http_response
2022-07-20T05:37:10.480 INFO:tasks.workunit.client.0.smithi116.stderr:    'http', request, response, code, msg, hdrs)
2022-07-20T05:37:10.481 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 570, in error
2022-07-20T05:37:10.481 INFO:tasks.workunit.client.0.smithi116.stderr:    return self._call_chain(*args)
2022-07-20T05:37:10.481 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 504, in _call_chain
2022-07-20T05:37:10.481 INFO:tasks.workunit.client.0.smithi116.stderr:    result = func(*args)
2022-07-20T05:37:10.482 INFO:tasks.workunit.client.0.smithi116.stderr:  File "/usr/lib64/python3.6/urllib/request.py", line 650, in http_error_default
2022-07-20T05:37:10.482 INFO:tasks.workunit.client.0.smithi116.stderr:    raise HTTPError(req.full_url, code, msg, hdrs, fp)
2022-07-20T05:37:10.482 INFO:tasks.workunit.client.0.smithi116.stderr:urllib.error.HTTPError: HTTP Error 504: Gateway Timeout


Related issues 2 (0 open2 closed)

Copied to Orchestrator - Backport #56737: pacific: cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway TimeoutResolvedAdam KingActions
Copied to Orchestrator - Backport #56738: quincy: cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway TimeoutResolvedAdam KingActions
Actions #1

Updated by Laura Flores over 1 year ago

Affects Pacific

/a/yuriw-2022-07-20_14:47:28-rados-wip-yuri2-testing-2022-07-15-0755-pacific-distro-default-smithi/6940660

Actions #2

Updated by Kamoltat (Junior) Sirivadhna over 1 year ago

  • Subject changed from pacific: cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway Timeout to cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway Timeout
  • Backport set to quincy, pacific
  • Affected Versions v17.2.2 added

Affects quincy:

/a/yuriw-2022-07-22_03:30:40-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6943754/

Actions #3

Updated by Kamoltat (Junior) Sirivadhna over 1 year ago

  • Affected Versions deleted (v17.2.2)
Actions #4

Updated by Kamoltat (Junior) Sirivadhna over 1 year ago

/a/yuriw-2022-07-22_03:30:40-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6944048/

Actions #5

Updated by Kamoltat (Junior) Sirivadhna over 1 year ago

/a/yuriw-2022-07-22_03:30:40-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6944406/

Actions #6

Updated by Adam King over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Adam King
  • Pull request ID set to 47269

it looks like we need just needed to update the test to use "main" instead of "master". Both instances of "test_cephadm_repos" passed in https://pulpito.ceph.com/adking-2022-07-26_01:35:13-orch:cephadm-wip-adk-testing-2022-07-25-1649-distro-default-smithi/ (ignore all the dead rhel jobs, unrelated)

Actions #7

Updated by Kamoltat (Junior) Sirivadhna over 1 year ago

/a/yuriw-2022-07-24_15:38:21-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6946359
/a/yuriw-2022-07-24_15:38:21-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6946383
/a/yuriw-2022-07-24_15:38:21-rados-wip-yuri3-testing-2022-07-21-1604-distro-default-smithi/6946371

Actions #8

Updated by Adam King over 1 year ago

  • Status changed from In Progress to Pending Backport
Actions #9

Updated by Backport Bot over 1 year ago

  • Copied to Backport #56737: pacific: cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway Timeout added
Actions #10

Updated by Backport Bot over 1 year ago

  • Copied to Backport #56738: quincy: cephadm/test_repos.sh: rllib.error.HTTPError: HTTP Error 504: Gateway Timeout added
Actions #11

Updated by Backport Bot over 1 year ago

  • Tags set to backport_processed
Actions #12

Updated by Adam King over 1 year ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF