Project

General

Profile

Actions

Feature #55277

closed

mgr/telemetry: add metric to gauge number of Rook clusters

Added by Laura Flores about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
telemetry module
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

In the 2022-04-11 Engineering Weekly call, there was discussion on using Telemetry to gauge how many of opted-in clusters use Rook.

Telemetry already gathers cluster config metrics in the basic channel that may reveal whether or not the Rook module is enabled (see `cluster_changed`). However, it is important to note that not all Rook users have the Rook module enabled. It's possible that a new data point will need to be added specifically for Rook usage, regardless of the module.


Related issues 1 (0 open1 closed)

Is duplicate of mgr - Feature #55740: Add "rook" structure to Ceph telemetryResolvedYaarit Hatuka

Actions
Actions #1

Updated by Yaarit Hatuka about 2 years ago

  • Assignee deleted (Yaarit Hatuka)
Actions #2

Updated by Yaarit Hatuka about 2 years ago

  • Status changed from New to Duplicate
Actions #3

Updated by Yaarit Hatuka about 2 years ago

  • Is duplicate of Feature #55740: Add "rook" structure to Ceph telemetry added
Actions

Also available in: Atom PDF