Project

General

Profile

Bug #55112

cephfs-shell: saving files doesn't work as expected

Added by Jeff Layton 8 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs-shell
Labels (FS):
task(easy)
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The "get" command in cephfs-shell doesn't behave as expected. Suppose I do this to save a file in a directory that lives on cephfs:

CephFS:~/volumes/_nogroup/client1/6a0ce533-aa3d-4413-aada-43757ed11949/dir>>> get c4BCAcYhN5u8K9c0mUaIEQ /tmp/foo

My assumption is that this is modeled after the old command-line ftp program. If so, then I would expect that that would save the file in a local file called "/tmp/foo", but instead it creates a directory "/tmp/foo" and stores a file called c4BCAcYhN5u8K9c0mUaIEQ in there.

When using the get command on a single file, it should attempt to save the file directly to the filename specified, and only if the terminating dentry turns out to already be a directory should it then save the file inside it. It should never create a directory on its own like this.


Related issues

Copied to CephFS - Backport #55629: pacific: cephfs-shell: saving files doesn't work as expected Resolved
Copied to CephFS - Backport #55630: quincy: cephfs-shell: saving files doesn't work as expected Resolved

History

#1 Updated by Venky Shankar 8 months ago

  • Category set to Correctness/Safety
  • Status changed from New to Triaged
  • Assignee set to Dhairya Parmar
  • Target version set to v18.0.0
  • Source set to Community (dev)
  • Backport set to quincy, pacific
  • Component(FS) cephfs-shell added
  • Labels (FS) task(easy) added

#2 Updated by Dhairya Parmar 8 months ago

  • Pull request ID set to 45797

#3 Updated by Venky Shankar 7 months ago

  • Status changed from Triaged to Pending Backport

#4 Updated by Backport Bot 7 months ago

  • Copied to Backport #55629: pacific: cephfs-shell: saving files doesn't work as expected added

#5 Updated by Backport Bot 7 months ago

  • Copied to Backport #55630: quincy: cephfs-shell: saving files doesn't work as expected added

#6 Updated by Dhairya Parmar 7 months ago

  • Pull request ID changed from 45797 to 45829

#7 Updated by Dhairya Parmar 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF