Project

General

Profile

Bug #5161

daemons should create /var/run/ceph if it doesn't already exist

Added by jianpeng ma about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I wanted to add a new mon into a cluster.But when i exce "ceph-mon -i majianpeng --mkfs --monmap map --keyring key", it print the following messages:

2013-05-24 10:37:26.795665 7f446912e7c0 -1 asok(0x1440000) AdminSocketConfigObs::init: failed: >AdminSocket::bind_and_listen: failed to bind the UNIX domain socket to '/var/run/ceph/ceph-mon.majianpeng.asok': (2) No >such file or directory
ceph-mon: created monfs at /var/lib/ceph/mon/mon.majianpeng for mon.majianpeng

I think the reason is there is not /var/run/ceph.
After I created the directory, then exec again.It's ok.

In document on ceph.com,there is no guide to do this.
I think we should create /var/run/ceph automaticly if there is no this director.

History

#1 Updated by Anonymous about 7 years ago

  • Priority changed from Normal to High

#2 Updated by Sage Weil about 7 years ago

  • Subject changed from Meet error on add a new monitor to daemons should create /var/run/ceph if it doesn't already exist
  • Priority changed from High to Normal

#3 Updated by Sage Weil about 7 years ago

  • Priority changed from Normal to High

#4 Updated by Sage Weil about 7 years ago

  • Status changed from New to Pending Backport

#5 Updated by Sage Weil about 7 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF