Project

General

Profile

Bug #51590

cephadm: iscsi: The first gateway defined must be the local machine

Added by Sebastian Wagner 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

1. Deploy cluster using cephadm
2. Deploy iscsi services using iscsi.yml file

[ceph: root@magna007 ~]# cat iscsi.yml 
service_type: iscsi
service_id: iscsi
placement:
  hosts:
  - host1
  - host2
spec:
  pool: iscsi_pool
  trusted_ip_list: "10.8.128.108,10.8.128.113" 
  api_user: admin
  api_password: admin

3. Login to container using "podman exec -it 12e38d148b25 /bin/sh" then do gwcli
4. Create target and gateways

[root@host1 ~]# podman exec -it 99b46c7235da sh

sh-4.4# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
10.8.128.108 host1 host1
10.8.128.113 host2 host2
127.0.1.1 host1 host1 ceph-3ce40d5c-dd5a-11eb-8a7a-002590fc2538-iscsi.iscsi.host1.kkxugr-tcmu

sh-4.4# gwcli
/iscsi-targets> create target_iqn=iqn.2003-01.com.example.iscsi-gw:ceph-igw
ok
/iscsi-targets> ls
o- iscsi-targets ................................................................................. [DiscoveryAuth: None, Targets: 1]
  o- iqn.2003-01.com.example.iscsi-gw:ceph-igw ............................................................ [Auth: None, Gateways: 0]
    o- disks ............................................................................................................ [Disks: 0]
    o- gateways .............................................................................................. [Up: 0/0, Portals: 0]
    o- host-groups .................................................................................................... [Groups : 0]
    o- hosts ......................................................................................... [Auth: ACL_ENABLED, Hosts: 0]
/iscsi-targets> goto gateways

/iscsi-target...-igw/gateways> create host1.ceph.example.com 10.8.128.108
The first gateway defined must be the local machine
/iscsi-target...-igw/gateways> create host2.ceph.example.com 10.8.128.113
The first gateway defined must be the local machine
/iscsi-target...-igw/gateways> create host1 10.8.128.108
The first gateway defined must be the local machine
/iscsi-target...-igw/gateways> create host2 10.8.128.113
The first gateway defined must be the local machine
/iscsi-target...-igw/gateways> create ceph-3ce40d5c-dd5a-11eb-8a7a-002590fc2538-iscsi.iscsi.host1.kkxugr-tcmu 10.8.128.108
Adding gateway, sync'ing 0 disk(s) and 0 client(s)
Failed : Gateway 'ceph-3ce40d5c-dd5a-11eb-8a7a-002590fc2538-iscsi.iscsi.host1.kkxugr-tcmu' is not resolvable to an IP address

Related issues

Duplicated by Orchestrator - Bug #51571: cephadm: remove iscsi service fails due to incorrect gateway name Resolved

History

#1 Updated by Sebastian Wagner 3 months ago

  • Status changed from New to In Progress
  • Pull request ID set to 42242

#2 Updated by Sebastian Wagner 3 months ago

  • Duplicated by Bug #51571: cephadm: remove iscsi service fails due to incorrect gateway name added

#3 Updated by Ken Dreyer about 2 months ago

  • Backport set to pacific

#4 Updated by Sebastian Wagner about 2 months ago

  • Status changed from In Progress to Pending Backport

#5 Updated by Ken Dreyer about 1 month ago

#6 Updated by Ken Dreyer about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF