Project

General

Profile

Bug #51528

400 error caused by multi-subtag language in Accept-Language header

Added by 玮文 胡 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
i18n
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Reproduced by Firefox for Android in Chinese.

The sent Accept-Language header is: zh-Hans-CN,en-CN;q=0.5

The response is:

{"status": "400 Bad Request", "detail": "Malformed 'Accept-Language' header", "request_id": "f9c0bfb0-8974-46ec-84e7-fe7bfe9f4d7a"}


Related issues

Copied to Dashboard - Backport #51558: pacific: 400 error caused by multi-subtag language in Accept-Language header Resolved

History

#1 Updated by Kefu Chai 5 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 42183

#2 Updated by Alfonso Martínez 5 months ago

  • Assignee set to 玮文 胡
  • Backport set to pacific

#3 Updated by Alfonso Martínez 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot 5 months ago

  • Copied to Backport #51558: pacific: 400 error caused by multi-subtag language in Accept-Language header added

#5 Updated by Ernesto Puerta 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF