Project

General

Profile

Actions

Bug #50592

closed

"ceph orch apply <svc_type>" applies placement by default without providing any output

Added by Juan Miguel Olmo Martínez almost 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
low-hanging-fruit
Backport:
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

[ceph: root@magna094 /]# ceph orch apply mon 
Scheduled mon update...
[ceph: root@magna094 /]# ceph orch apply mgr
Scheduled mgr update...

The user can always retrieve the service information uisng "ceph orch ls <service> --format yaml"... but is more friendly if we do:

[ceph: root@cephLab2-node-00 /]# ceph orch apply mon
Saving service mon spec with placement count:5
Scheduled mon update...

[ceph: root@cephLab2-node-00 /]# ceph orch apply mgr
Saving service mgr spec with placement count:2
Scheduled mgr update...

Actions #1

Updated by Juan Miguel Olmo Martínez almost 3 years ago

  • % Done changed from 0 to 50
  • Pull request ID set to 38689
Actions #2

Updated by Sebastian Wagner almost 3 years ago

  • Status changed from New to Fix Under Review
Actions #3

Updated by Sebastian Wagner over 2 years ago

  • Status changed from Fix Under Review to New
  • Assignee deleted (Juan Miguel Olmo Martínez)
  • % Done changed from 50 to 0
  • Tags set to low-hanging-fruit
Actions #4

Updated by Redouane Kachach Elhichou about 2 years ago

The changes requiered for this enhancement are very simple (adding a the phrase 'Saving service name...' to the output. However, this simple change breaks a lot of unit test cases which are expecting only "Scheduled service_name update..." in the output. I'm closing this BUG since it's a 'nice to have' feature which could be obtained by other cephadm commands.

Actions #5

Updated by Redouane Kachach Elhichou about 2 years ago

  • Status changed from New to Won't Fix
Actions #6

Updated by Redouane Kachach Elhichou about 2 years ago

  • Status changed from Won't Fix to Closed
Actions #7

Updated by Sebastian Wagner about 2 years ago

Redouane Kachach Elhichou wrote:

The changes requiered for this enhancement are very simple (adding a the phrase 'Saving service name...' to the output. However, this simple change breaks a lot of unit test cases which are expecting only "Scheduled service_name update..." in the output. I'm closing this BUG since it's a 'nice to have' feature which could be obtained by other cephadm commands.

Why not fix the unit tests instead?

Actions

Also available in: Atom PDF