Project

General

Profile

Actions

Bug #49535

closed

nautilus: mgr/balancer: KeyError messages in balancer module

Added by Nikola Ciprich over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
balancer module
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

we've encountered balancer crashes on one of our clusters. I wonder if it might be caused by filestore OSD, since it's crashing on it (ie osd.7 is for some reason filestore, while most of the others are bluestores)

backtrace:

Feb 24 14:17:08 magpejv1a ceph-mgr2583: File "/usr/share/ceph/mgr/balancer/module.py", line 657, in serve
Feb 24 14:17:08 magpejv1a ceph-mgr2583: r, detail = self.optimize(plan)
Feb 24 14:17:08 magpejv1a ceph-mgr2583: File "/usr/share/ceph/mgr/balancer/module.py", line 928, in optimize
Feb 24 14:17:08 magpejv1a ceph-mgr2583: return self.do_crush_compat(plan)
Feb 24 14:17:08 magpejv1a ceph-mgr2583: File "/usr/share/ceph/mgr/balancer/module.py", line 1089, in do_crush_compat
Feb 24 14:17:08 magpejv1a ceph-mgr2583: weight = best_ws[osd]
Feb 24 14:17:08 magpejv1a ceph-mgr2583: KeyError: 7

some time ago, I've reported similar problem which already got fixed: https://tracker.ceph.com/issues/42721


Files

map.gz (4.21 KB) map.gz Nikola Ciprich, 02/27/2021 06:52 PM

Related issues 1 (0 open1 closed)

Is duplicate of mgr - Bug #49576: mgr/balancer: KeyError messages in balancer moduleResolvedNeha Ojha

Actions
Actions #1

Updated by Neha Ojha over 3 years ago

  • Status changed from New to Duplicate
Actions #2

Updated by Neha Ojha over 3 years ago

  • Is duplicate of Bug #49576: mgr/balancer: KeyError messages in balancer module added
Actions #3

Updated by Neha Ojha over 3 years ago

Actions

Also available in: Atom PDF