Project

General

Profile

Bug #49522

cephadm: ValueError: not enough values to unpack (expected 2, got 1)

Added by Sage Weil about 2 months ago. Updated 29 days ago.

Status:
Resolved
Priority:
Immediate
Category:
cephadm (binary)
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-02-26T20:20:09.116+0000 7fdbcb76b700  0 [cephadm DEBUG root] err: Pulling container image quay.ceph.io/ceph-ci/ceph:d5d0b807b6370ff5be0fe6da3344ff33013528bc...
Traceback (most recent call last):
  File "<stdin>", line 6152, in <module>
  File "<stdin>", line 1393, in _infer_image
  File "<stdin>", line 2691, in command_pull
  File "<stdin>", line 1393, in _infer_image
  File "<stdin>", line 2731, in command_inspect_image
  File "<stdin>", line 2742, in get_image_info_from_inspect
ValueError: not enough values to unpack (expected 2, got 1)

podman version 2.2.1

this is breaking most of the upgrade tests, since we can't pull the target image from the old cephadm version


Related issues

Related to Orchestrator - Bug #48924: cephadm: upgrade process failed to pull target image: not enough values to unpack (expected 2, got 1) (podman 2.2.1 breakage) Resolved

History

#1 Updated by Michael Fritch about 2 months ago

  • Category set to cephadm (binary)
  • Assignee set to Sebastian Wagner
  • Target version set to v15.2.9
  • Pull request ID set to 39715

#2 Updated by Sage Weil about 1 month ago

workaround by not testing on centos/rhel for now: https://github.com/ceph/ceph/pull/39791

#3 Updated by Sebastian Wagner about 1 month ago

  • Related to Bug #48924: cephadm: upgrade process failed to pull target image: not enough values to unpack (expected 2, got 1) (podman 2.2.1 breakage) added

#5 Updated by Sebastian Wagner about 1 month ago

  • Status changed from New to Resolved

#6 Updated by Nathan Cutler 29 days ago

  • Target version changed from v15.2.9 to v15.2.10

Also available in: Atom PDF