Project

General

Profile

Actions

Bug #49228

closed

qa/tasks/cephadm.py: file changed as we read it

Added by Neha Ojha over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-02-08T16:18:29.973 INFO:tasks.cephadm:Compressing logs...
2021-02-08T16:18:29.973 DEBUG:teuthology.orchestra.run.smithi075:> sudo find /var/log/ceph -name *.log -print0 | sudo xargs -0 --no-run-if-empty -- gzip --
2021-02-08T16:18:30.021 DEBUG:teuthology.orchestra.run.smithi087:> sudo find /var/log/ceph -name *.log -print0 | sudo xargs -0 --no-run-if-empty -- gzip --
2021-02-08T16:18:30.030 INFO:tasks.cephadm:Archiving logs...
2021-02-08T16:18:30.030 DEBUG:teuthology.misc:Transferring archived files from smithi075:/var/log/ceph to /home/teuthworker/archive/swagner-2021-02-08_09:51:29-rados:cephadm-wip-swagner-testing-2021-02-05-1350-distro-basic-smithi/5867503/remote/ubuntu@smithi075.front.sepia.ceph.com/log
2021-02-08T16:18:30.034 DEBUG:teuthology.orchestra.run.smithi075:> sudo tar cz -f - -C /var/log/ceph -- .
2021-02-08T16:18:30.240 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-osd.0.log: file changed as we read it
2021-02-08T16:18:30.241 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-volume.log: File removed before we read it
2021-02-08T16:18:30.403 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-mon.a.log: file changed as we read it
2021-02-08T16:18:30.552 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-osd.2.log: file changed as we read it
2021-02-08T16:18:30.688 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-mgr.a.log: file changed as we read it
2021-02-08T16:18:30.842 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c/ceph-osd.1.log: file changed as we read it
2021-02-08T16:18:30.844 INFO:teuthology.orchestra.run.smithi075.stderr:tar: ./b51cc71a-6a27-11eb-8fde-001a4aab830c: file changed as we read it

/a/swagner-2021-02-08_09:51:29-rados:cephadm-wip-swagner-testing-2021-02-05-1350-distro-basic-smithi/5867503

nojha@teuthology:/ceph/teuthology-archive/swagner-2021-02-08_09:51:29-rados:cephadm-wip-swagner-testing-2021-02-05-1350-distro-basic-smithi/5867503/remote/ubuntu@smithi075.front.sepia.ceph.com/log/b51cc71a-6a27-11eb-8fde-001a4aab830c$ ls
ceph-mgr.a.log  ceph-mon.a.log  ceph-osd.0.log  ceph-osd.0.log.gz  ceph-osd.1.log  ceph-osd.2.log

Caused by 6d7ba1180e66df2d6dee3a01fe3e12cafaa6fe8c, so reverting it like its ceph task counterpart https://github.com/ceph/ceph/pull/38252

Actions #1

Updated by Neha Ojha over 3 years ago

  • Backport set to pacific
  • Pull request ID set to 39384

In pacific

2021-02-09T21:19:36.711 INFO:tasks.cephadm:Archiving logs...
2021-02-09T21:19:36.712 DEBUG:teuthology.misc:Transferring archived files from smithi014:/var/log/ceph to /home/teuthworker/archive/swagner-2021-02-09_10:28:14-rados:cephadm-wip-swagner2-testing-2021-02-08-1109-pacific-distro-basic-smithi/5871371/remote/ubuntu@smithi014.front.sepia.ceph.com/log
2021-02-09T21:19:36.713 DEBUG:teuthology.orchestra.run.smithi014:> sudo tar cz -f - -C /var/log/ceph -- .
2021-02-09T21:19:37.393 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-mon.c.log: file changed as we read it
2021-02-09T21:19:39.192 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-mon.a.log: file changed as we read it
2021-02-09T21:19:39.206 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/objectstore_tool.1.log: File removed before we read it
2021-02-09T21:19:39.207 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-client.rgw.realm.zone.a.log: File removed before we read it
2021-02-09T21:19:46.445 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-osd.3.log: file changed as we read it
2021-02-09T21:19:47.113 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-mgr.y.log: file changed as we read it
2021-02-09T21:20:03.105 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-osd.2.log: file changed as we read it
2021-02-09T21:20:19.787 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-osd.0.log: file changed as we read it
2021-02-09T21:20:32.370 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-osd.1.log: file changed as we read it
2021-02-09T21:20:32.663 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c/ceph-volume.log: File removed before we read it
2021-02-09T21:20:32.663 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./767d6ee6-6b18-11eb-8fe7-001a4aab830c: file changed as we read it
2021-02-09T21:20:32.663 INFO:teuthology.orchestra.run.smithi014.stderr:tar: ./cephadm.log: File removed before we read it
2021-02-09T21:20:32.663 INFO:teuthology.orchestra.run.smithi014.stderr:tar: .: file changed as we read it

/a/swagner-2021-02-09_10:28:14-rados:cephadm-wip-swagner2-testing-2021-02-08-1109-pacific-distro-basic-smithi/5871371

Actions #2

Updated by Neha Ojha over 3 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF