Project

General

Profile

Actions

Documentation #48267

closed

orchestrator docs should at least mention keyrings

Added by David Galloway over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

I had to use Suse's docs to add a host to the LRC.

root@reesi001:~# ceph orch --id admin daemon add osd o06.vlan105.sepia.ceph.com:/dev/nvme4n1
Error EINVAL: Traceback (most recent call last):
  File "/usr/share/ceph/mgr/mgr_module.py", line 1177, in _handle_command
    return self.handle_command(inbuf, cmd)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 141, in handle_command
    return dispatch[cmd['prefix']].call(self, cmd, inbuf)
  File "/usr/share/ceph/mgr/mgr_module.py", line 318, in call
    return self.func(mgr, **kwargs)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 103, in <lambda>
    wrapper_copy = lambda *l_args, **l_kwargs: wrapper(*l_args, **l_kwargs)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 92, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/ceph/mgr/orchestrator/module.py", line 755, in _daemon_add_osd
    raise_if_exception(completion)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 643, in raise_if_exception
    raise e
mgr_module.MonCommandFailed: auth get failed: failed to find client.bootstrap-osd in keyring retval: -2

Need to create the key then add it to the keyring. Only figured this out after stumbling on https://documentation.suse.com/ses/5.5/html/ses-all/app-storage-manual-inst.html

Actions #1

Updated by Sebastian Wagner about 3 years ago

  • Project changed from Ceph to Orchestrator
Actions #2

Updated by Sebastian Wagner about 3 years ago

  • Status changed from New to Can't reproduce
Actions #3

Updated by Sebastian Wagner about 3 years ago

  • Status changed from Can't reproduce to New
Actions #4

Updated by Sebastian Wagner almost 3 years ago

  • Priority changed from Normal to Low
Actions #6

Updated by Sage Weil almost 3 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF