Project

General

Profile

Bug #47662

mds: try to replicate hot dir to restarted MDS

Added by Zhi Zhang 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
multimds
Pull request ID:
Crash signature:

Description

Hot dir would be replicated to other active MDSes, but if replica MDS restarted, auth MDS won't replicate this dir again even if it is still hot. This is because dir's dir_rep is set and dir is still hot, dir's dir_rep won't be unset.

So try to compare the active MDSes with dir's replica set, and replicat it to the MDS whom hasn't contain this dir's replica.

History

#1 Updated by Zhi Zhang 4 months ago

  • Pull request ID set to 37428

#2 Updated by Patrick Donnelly 4 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Zhi Zhang
  • Target version set to v16.0.0

#3 Updated by Patrick Donnelly about 1 month ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF