Project

General

Profile

Bug #47628

sphinx-autodoc-typehints 1.11.0 requires Sphinx>=3.0, but you'll have sphinx 2.4.3 which is incompatible

Added by Nathan Cutler 2 months ago. Updated 2 months ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I looked into the `Docs: build check` failure in octopus backport PR https://github.com/ceph/ceph/pull/37142 and this message popped out at me:

+ ./admin/build-doc
Top Level States:  ['PeeringMachine']
Already using interpreter /usr/bin/python3
Using base prefix '/usr'
New python executable in /home/jenkins-build/build/workspace/ceph-pr-docs/build-doc/virtualenv/bin/python3
Also creating executable in /home/jenkins-build/build/workspace/ceph-pr-docs/build-doc/virtualenv/bin/python
Installing setuptools, pkg_resources, pip, wheel...done.
ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

sphinx-autodoc-typehints 1.11.0 requires Sphinx>=3.0, but you'll have sphinx 2.4.3 which is incompatible.

It's not clear to me how "sphinx-autodoc-typehints 1.11.0" is getting installed in the Jenkins environment.


Related issues

Copied to Ceph - Backport #47632: octopus: sphinx-autodoc-typehints 1.11.0 requires Sphinx>=3.0, but you'll have sphinx 2.4.3 which is incompatible In Progress

History

#1 Updated by Nathan Cutler 2 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 37389

#2 Updated by Nathan Cutler 2 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Assignee set to Kefu Chai
  • Backport set to octopus
  • Pull request ID changed from 37389 to 33888

#3 Updated by Kefu Chai 2 months ago

  • Copied to Backport #47632: octopus: sphinx-autodoc-typehints 1.11.0 requires Sphinx>=3.0, but you'll have sphinx 2.4.3 which is incompatible added

Also available in: Atom PDF