Project

General

Profile

Bug #47060

All ragweed tests failing

Added by J. Eric Ivancich 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description


2020-08-20T18:29:47.436 INFO:teuthology.orchestra.run.smithi146:ragweed tests against rgw> RAGWEED_CONF=/home/ubuntu/cephtest/archive/ragweed.client.0.conf RAGWEED_STAGES=prepare,check BOTO_CONFIG=/home/ubuntu/cephtest/boto.cfg /home/ubuntu/cephtest/ragweed/virtualenv/bin/python -m nose -w /home/ubuntu/cephtest/ragweed -v -a '!fails_on_rgw'
2020-08-20T18:29:47.810 INFO:teuthology.orchestra.run.smithi146.stderr:ERROR
2020-08-20T18:29:47.810 INFO:teuthology.orchestra.run.smithi146.stderr:
2020-08-20T18:29:47.810 INFO:teuthology.orchestra.run.smithi146.stderr:======================================================================
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:ERROR: test suite for <module 'ragweed.tests.tests' from '/home/ubuntu/cephtest/ragweed/ragweed/tests/tests.py'>
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:----------------------------------------------------------------------
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:Traceback (most recent call last):
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python3.6/site-packages/nose/suite.py", line 210, in run
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:    self.setUp()
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python3.6/site-packages/nose/suite.py", line 293, in setUp
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:    self.setupContext(ancestor)
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python3.6/site-packages/nose/suite.py", line 316, in setupContext
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:    try_run(context, names)
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python3.6/site-packages/nose/util.py", line 471, in try_run
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:    return func()
2020-08-20T18:29:47.811 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/ragweed/framework.py", line 460, in setup_module
2020-08-20T18:29:47.812 INFO:teuthology.orchestra.run.smithi146.stderr:    ragweed_env = RagweedEnv()
2020-08-20T18:29:47.812 INFO:teuthology.orchestra.run.smithi146.stderr:  File "/home/ubuntu/cephtest/ragweed/ragweed/framework.py", line 449, in __init__
2020-08-20T18:29:47.812 INFO:teuthology.orchestra.run.smithi146.stderr:    self.rados.connect()
2020-08-20T18:29:47.818 INFO:teuthology.orchestra.run.smithi146.stderr:  File "rados.pyx", line 1003, in rados.Rados.connect
2020-08-20T18:29:47.818 INFO:teuthology.orchestra.run.smithi146.stderr:rados.ObjectNotFound: [errno 2] RADOS object not found (error connecting to the cluster)

Related issues

Duplicates RADOS - Bug #47002: python-rados: connection error Resolved

History

#2 Updated by Kefu Chai 5 months ago

  • Description updated (diff)

#3 Updated by Brad Hubbard 5 months ago

Sorry I didn't make much progress with this on Friday.

I can reproduce this using /a/yuriw-2020-08-20_19:13:00-upgrade:nautilus-x-wip-yuri3-testing-2020-08-20-1741-master-distro-basic-smithi/5362858/orig.config.yaml

# extension module 'rados' loaded from '/usr/lib/python3/dist-packages/rados.cpython-36m-x86_64-linux-gnu.so'
# extension module 'rados' executed from '/usr/lib/python3/dist-packages/rados.cpython-36m-x86_64-linux-gnu.so'
import 'rados' # <_frozen_importlib_external.ExtensionFileLoader object at 0x7f47d3ceb7f0>
>>> rados = rados.Rados(conffile="/etc/ceph/ceph.conf", name='client.admin')
>>> rados.connect()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "rados.pyx", line 1003, in rados.Rados.connect
rados.ObjectNotFound: [errno 2] RADOS object not found (error connecting to the cluster)
>>> rados.conf_get('fsid')
'd436c0de-5f07-4266-a1ca-c2729480adc7'
>>> rados.conf_get('mon host')
'172.21.15.137,172.21.15.162,172.21.15.6'
>>> rados.conf_get('clustername')
>>> 

New python session.

$ python    
Python 3.6.9 (default, Jul 17 2020, 12:50:27) 
[GCC 8.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import rados
>>> rados = rados.Rados(clustername='ceph', conffile="/etc/ceph/ceph.conf", name='client.admin')
>>> rados.connect()
>>> rados.get_cluster_stats()
{'kb': 1132462080, 'kb_used': 13240608, 'kb_avail': 1119221472, 'num_objects': 411}

So this is a duplicate of #47002

#4 Updated by Brad Hubbard 5 months ago

  • Duplicates Bug #47002: python-rados: connection error added

#5 Updated by Kefu Chai 5 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF