Project

General

Profile

Bug #45903

BlueFS replay log grows without end

Added by Adam Kupczyk 9 months ago. Updated 28 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
% Done:

0%

Source:
Support
Tags:
Backport:
luminous,mimic,nautilus,octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

If data is slowly pouring to RocksDB WAL and new files are not created, BlueFS replay log can grow to the size that it no longer can be replayed.


Related issues

Copied to bluestore - Backport #46192: mimic: BlueFS replay log grows without end Rejected
Copied to bluestore - Backport #46193: octopus: BlueFS replay log grows without end Resolved
Copied to bluestore - Backport #46194: nautilus: BlueFS replay log grows without end Resolved
Copied to bluestore - Backport #46195: luminous: BlueFS replay log grows without end Resolved

History

#1 Updated by Igor Fedotov 9 months ago

Seen that to. Looks like we're lacking some backports in luminous.
See https://github.com/ceph/ceph/pull/34876

#2 Updated by Neha Ojha 8 months ago

  • Status changed from New to Pending Backport
  • Backport set to luminous,mimic,nautilus,octopus
  • Pull request ID set to 35473

It will be good to get the fix into luminous and mimic for affected users.

#3 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #46192: mimic: BlueFS replay log grows without end added

#4 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #46193: octopus: BlueFS replay log grows without end added

#5 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #46194: nautilus: BlueFS replay log grows without end added

#6 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #46195: luminous: BlueFS replay log grows without end added

#7 Updated by Nathan Cutler 28 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF