Project

General

Profile

Bug #45245

cephadm: print iscsi container's log to stdout/stderr

Added by Kiefer Chang 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

rbd-target-api's log lives in /var/log/rbd-target-api/rbd-target-api.log inside container.
We should print the log to stdout to allow users to get the log via podman and journald.

History

#1 Updated by Matthew Oliver 5 months ago

  • Assignee set to Matthew Oliver

Ceph-iscsi logging is hardcoded to go point to /dev/log, I don't think ceph-iscsi has an option to log to stderr. But I can take a look and maybe patch it. But if that is the case we need to raise a bug/feature for ceph-iscsi.

Let me take a look.

#2 Updated by Matthew Oliver 5 months ago

OK so if it's just needing access to the logs via something like journald and journalctl then that should currently work. We should be writing logs to /dev/log which is mounted into the container. If it isn't then maybe we have another permissions issue.

^^ I say that, because I can see the logs via journalctl on my host, but I am running it as a --priviliged container, as this is the same env I was testing stuff for the other bug.

If we need to have it logging to stderr, then I've got some code that should work that I can push up as a PR the ceph-iscsi if that's what we need. Just want to confirm before we do anything.

#3 Updated by Sebastian Wagner 4 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 35013

#4 Updated by Sebastian Wagner 4 months ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v15.2.4

Also available in: Atom PDF