Project

General

Profile

Bug #45104

NFS deployed using orchestrator watch_url not working and mkdirs permission denied dashboard

Added by mitchell walls 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Community (user)
Tags:
cephadm nfs
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Component(FS):
Ganesha FSAL
Labels (FS):
Pull request ID:
Crash signature:

Description

I've ran into two issues after deploying ceph using cephadm all default for the nfs side.

Running ceph orch apply nfs ...
I then set the ganesha rados url for the dashboard.
Going into dashboard then creating an export will give mkdirs permission denied trying to create the path.
If I go into the filesystem then modify the root permissions to 777 it works. Is this as intended?
I originally used manila for my nfs shares and haven't had to do that.
Also I noticed an error for the dashboard api request lsdir gives a 500 error even after fixing the permissions.

Now I create an nfs share after fixing permissions.
Go to mount the new export and it gives me no such file or directory.
Check the pool namespace to see if the export is created I see it there.
Then go into the ganesha container and run `kill -1 1` afterwards the export works.

Figured the watch_url isn't working so I checked the object using listwatchers and don't see anything in the list.
Attached a watcher to it then created another share and I got a notify from the new export creation.
Set the ganesha container log level to FULL_DEBUG and checked logs and don't see anthing about watch url except:
do_block_load :CONFIG :F_DBG :0x7f9ac03092f0 name=watch_url type=CONFIG_STRING

I plan to still use manila just figured I would test this out. Cephadm is awesome btw. :)

I will gladly post any information you need.

History

#1 Updated by mitchell walls 5 months ago

The mkdirs permission denied issue doesn't seem to be happening anymore even without root cephfs 777 permissions. Not sure what was causing it.

The watch_url issue still seems to be persisting even after swapping to a different host.

The workaround for now that i've been using is this everytime I add a new export:
podman kill --signal=SIGHUP `podman ps | grep STDERR | awk '{print$1}'`

#2 Updated by Jeff Layton 5 months ago

  • Assignee set to Jeff Layton

The watch_url problem is a known regression in ganesha. Fixed by:

https://github.com/nfs-ganesha/nfs-ganesha/commit/640e387774f462cf04f7c7a591c6f9d8199ce312

...to be clear though: what version of ganesha are you running?

#3 Updated by mitchell walls 5 months ago

It is the docker image so NFS-Ganesha Release = V3.2.

#4 Updated by Jeff Layton 5 months ago

Thanks! The relevant patch should make V2.8.4 and V3.3.

#5 Updated by Patrick Donnelly 5 months ago

  • Status changed from New to Closed

Also available in: Atom PDF