Project

General

Profile

Bug #45100

qa: Test failure: test_damaged_dentry (tasks.cephfs.test_damage.TestDamage)

Added by Ramana Raja 10 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
kceph, qa-suite
Labels (FS):
Pull request ID:
Crash signature:

Description

Hit this in the kcephfs suite of yuri's nautilus run, http://qa-proxy.ceph.com/teuthology/yuriw-2020-04-15_00:09:40-kcephfs-wip-yuri-testing-2020-04-14-1606-nautilus-distro-basic-smithi/4954403/teuthology.log

2020-04-15T07:47:45.852 INFO:tasks.cephfs_test_runner:======================================================================
2020-04-15T07:47:45.852 INFO:tasks.cephfs_test_runner:FAIL: test_damaged_dentry (tasks.cephfs.test_damage.TestDamage)
2020-04-15T07:47:45.852 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2020-04-15T07:47:45.853 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2020-04-15T07:47:45.853 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-yuri-testing-2020-04-14-1606-nautilus/qa/tasks/cephfs/test_damage.py", line 446, in test_damaged_dentry
2020-04-15T07:47:45.853 INFO:tasks.cephfs_test_runner:    self.assertEqual(e.exitstatus, errno.ENOENT)
2020-04-15T07:47:45.853 INFO:tasks.cephfs_test_runner:AssertionError: 5 != 2
2020-04-15T07:47:45.853 INFO:tasks.cephfs_test_runner:

The test hits EIO, but expects to hit ENOENT. kernel client version is 5.7.0-rc1-ceph-gd78a6438525e

History

#1 Updated by Ramana Raja 10 months ago

  • Description updated (diff)

#2 Updated by Ramana Raja 10 months ago

  • Description updated (diff)

#3 Updated by Greg Farnum 9 months ago

Did you look to see if the test differs from master or we did a backport of something that changed behavior? Not sure which one this is but ENOENT is a very definitive thing whereas if we've detected damage EIO is often the right response...

#4 Updated by Patrick Donnelly 9 months ago

Octopus too: /ceph/teuthology-archive/yuriw-2020-05-09_21:30:44-kcephfs-wip-yuri-octopus_15.2.2_RC0-distro-basic-smithi/5040718/teuthology.log

It's a testing branch issue apparently.

#5 Updated by Patrick Donnelly 8 months ago

and master: /ceph/teuthology-archive/pdonnell-2020-06-12_09:37:27-kcephfs-wip-pdonnell-testing-20200612.063208-distro-basic-smithi/5141859/teuthology.log

#6 Updated by Patrick Donnelly 3 months ago

/ceph/teuthology-archive/pdonnell-2020-10-13_22:14:10-kcephfs-wip-pdonnell-testing-20201013.174240-distro-basic-smithi/5523850/teuthology.log

#7 Updated by Patrick Donnelly 3 months ago

  • Subject changed from nautilus: Test failure: test_damaged_dentry (tasks.cephfs.test_damage.TestDamage) to qa: Test failure: test_damaged_dentry (tasks.cephfs.test_damage.TestDamage)
  • Assignee set to Xiubo Li
  • Priority changed from Normal to Urgent
  • Target version set to v16.0.0
  • Component(FS) kceph added

#8 Updated by Xiubo Li 3 months ago

  • Status changed from New to In Progress

#9 Updated by Xiubo Li 3 months ago

For the Kclient:

When we first time to do the :

touch /mnt/cephfs/subdir/file_to_be_damaged

It drop the Fs cap and then the MDS will send and grant it back, then the complete flag for "subdir/" will be cleared. But this won't affect the following `stat /mnt/cephfs/subdir/file_to_be_damaged` commands' return values. Because the vfs layer will `dput(dentry)` the dentry once the atomic_open() fails, which will be called when doing the above touch command. So when next time we do stat, it will miss it in the dcache and then do a lookup from the MDS, which will fail with -EIO too.

#10 Updated by Xiubo Li 3 months ago

  • Pull request ID set to 37869

#11 Updated by Xiubo Li 3 months ago

  • Status changed from In Progress to Fix Under Review

#12 Updated by Patrick Donnelly 3 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF