Project

General

Profile

Bug #44972

cephadm: add-repo on ubuntu broken

Added by Sebastian Wagner over 1 year ago. Updated 27 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Right now this fails:

W: http://nl.archive.ubuntu.com/ubuntu/dists/bionic/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg.d/ceph.release.gpg are ignored as the file has an unsupported filetype.

Adding the repo key should be done via

`wget -q -O- 'https://download.ceph.com/keys/release.asc' | sudo apt-key add -

Related issues

Blocked by sepia - Bug #45009: https://download.ceph.com/keys/release.asc: ignored as the file has an unsupported filetype. Closed

History

#1 Updated by Sebastian Wagner over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Sebastian Wagner

#2 Updated by Sebastian Wagner over 1 year ago

Turns out apt-key is unusable by default:

root@buster:/cephadm# apt-key -h
E: gnupg, gnupg2 and gnupg1 do not seem to be installed, but one of them is required for this operation

In addition, apt-key ignores the .d directory:

root@buster:~# apt-key list
/etc/apt/trusted.gpg
--------------------
pub   rsa4096 2015-09-15 [SC]
      08B7 3419 AC32 B4E9 66C1  A330 E84A C2C0 460F 3994
uid           [ unknown] Ceph.com (release key) <security@ceph.com>

#3 Updated by Sebastian Wagner over 1 year ago

  • Blocked by Bug #45009: https://download.ceph.com/keys/release.asc: ignored as the file has an unsupported filetype. added

#4 Updated by Sebastian Wagner over 1 year ago

  • Status changed from In Progress to New

#5 Updated by Sebastian Wagner about 2 months ago

  • Assignee deleted (Sebastian Wagner)

#6 Updated by Adam King about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to Adam King

#7 Updated by Adam King about 2 months ago

  • Pull request ID set to 41813

#8 Updated by Sebastian Wagner 27 days ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF