Project

General

Profile

Bug #43807

osd-backfill-recovery-log.sh fails

Added by Sage Weil 25 days ago. Updated 21 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

2020-01-24T10:16:33.646 INFO:tasks.workunit.client.0.smithi134.stderr://home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:82: _common_test:  jq '.pg_log_t.log | length' td/osd-backfill-recovery-log/result.log
2020-01-24T10:16:33.646 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:82: _common_test:  LOGLEN=2
2020-01-24T10:16:33.647 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:83: _common_test:  '[' 2 '!=' 1 ']'
2020-01-24T10:16:33.647 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:84: _common_test:  echo 'FAILED: Wrong log length got 2 (expected 1)'
2020-01-24T10:16:33.647 INFO:tasks.workunit.client.0.smithi134.stderr://home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:85: _common_test:  expr 0 + 1
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:85: _common_test:  ERRORS=1
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr://home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:87: _common_test:  jq '.pg_log_t.dups | length' td/osd-backfill-recovery-log/result.log
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:87: _common_test:  DUPSLEN=8
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:88: _common_test:  '[' 8 '!=' 9 ']'
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:89: _common_test:  echo 'FAILED: Wrong dups length got 8 (expected 9)'
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr://home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:90: _common_test:  expr 1 + 1
2020-01-24T10:16:33.648 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:90: _common_test:  ERRORS=2
2020-01-24T10:16:33.649 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:92: _common_test:  grep 'copy_up_to\|copy_after' td/osd-backfill-recovery-log/osd.0.log td/osd-backfill-recovery-log/osd.1.log td/osd-backfill-recovery-log/osd.2.log td/osd-backfill-recovery-log/osd.3.log td/osd-backfill-recovery-log/osd.4.log td/osd-backfill-recovery-log/osd.5.log
2020-01-24T10:16:33.649 INFO:tasks.workunit.client.0.smithi134.stdout:FAILED: Wrong log length got 2 (expected 1)
2020-01-24T10:16:33.649 INFO:tasks.workunit.client.0.smithi134.stdout:FAILED: Wrong dups length got 8 (expected 9)
...
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stdout:TEST FAILED
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:93: _common_test:  rm -f td/osd-backfill-recovery-log/result.log
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:94: _common_test:  '[' 2 '!=' 0 ']'
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:95: _common_test:  echo TEST FAILED
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:96: _common_test:  return 1
2020-01-24T10:16:33.661 INFO:tasks.workunit.client.0.smithi134.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/osd/osd-backfill-recovery-log.sh:33: run:  return 1

/a/sage-2020-01-24_01:55:08-rados-wip-sage4-testing-2020-01-23-1347-distro-basic-smithi/4698015

History

#1 Updated by Josh Durgin 24 days ago

The test needs to be updated due to https://github.com/ceph/ceph/pull/32683 - anything else that sets the log lengths (like the rados suite facet) needs updating too. If the tests set osd_target_pg_log_entries_per_osd they can get a similar effect.

#2 Updated by Sage Weil 24 days ago

/a/sage-2020-01-24_13:15:58-rados-wip-sage2-testing-2020-01-23-1953-distro-basic-smithi/4701051

#3 Updated by Neha Ojha 24 days ago

  • Project changed from Ceph to RADOS

#4 Updated by Neha Ojha 24 days ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 32851

#5 Updated by Neha Ojha 24 days ago

  • Status changed from Fix Under Review to In Progress

#6 Updated by Neha Ojha 24 days ago

  • Status changed from In Progress to Fix Under Review
  • Assignee set to Neha Ojha

#7 Updated by Sage Weil 22 days ago

//a/sage-2020-01-24_23:29:53-rados-wip-sage2-testing-2020-01-24-1408-distro-basic-smithi/4703160

#8 Updated by Sage Weil 22 days ago

  • Target version set to v15.0.0

#9 Updated by Sage Weil 21 days ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF