Project

General

Profile

Bug #42716

Pool creation error message is hidden on FileStore-backed pools

Added by Dimitri Savineau 8 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
low-hanging-fruit
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Monitor
Pull request ID:
Crash signature:

Description

When trying to create a pool with an incorrect PG number then the error message is hidden by a warning message.

osd_objectstore: filestore

# ceph --version
ceph version 12.2.12-48.el7cp (26388d73d88602005946d4381cc5796d42904858) luminous (stable)
# ceph osd pool create foo 2048
Error ERANGE: For better initial performance on pools expected to store a large number of objects, consider supplying the expected_num_objects parameter when creating the pool.
# echo $?
34

It's actually hiding the real pool creation error.

# ceph osd pool create foo 2048 replicated_rule 1 1000000
Error ERANGE:  pg_num 2048 size 3 would mean 6504 total pgs, which exceeds max 6000 (mon_max_pg_per_osd 250 * num_in_osds 24)
# echo $?
34

This seems to be introduced by [1]

[1] https://github.com/ceph/ceph/commit/d10a5dddc46095ed9ddf9718fc13214b1d0e2af8

History

#1 Updated by Greg Farnum 8 months ago

  • Project changed from Ceph to RADOS
  • Subject changed from Pool creation error message not display to Pool creation error message is hidden on FileStore-backed pools
  • Category changed from Monitor to Administration/Usability
  • Component(RADOS) Monitor added

#2 Updated by Neha Ojha 8 months ago

  • Tags set to low-hanging-fruit

#3 Updated by Deepika Upadhyay 8 months ago

  • Assignee set to Deepika Upadhyay

#4 Updated by Deepika Upadhyay 5 months ago

  • Pull request ID set to 33281

#5 Updated by Deepika Upadhyay 5 months ago

  • Pull request ID deleted (33281)

#6 Updated by Deepika Upadhyay about 1 month ago

  • Status changed from New to Resolved

closing this as already resolved.


ideepika@vossi04 build]$ bin/ceph osd pool create foo2 204800 replicated_rule 1 1000000
*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
2020-06-09T19:37:34.351+0000 7fee923a9700 -1 WARNING: all dangerous and experimental features are enabled.
2020-06-09T19:37:34.363+0000 7fee91147700 -1 WARNING: all dangerous and experimental features are enabled.
Error ERANGE: 'pg_num' must be greater than 0 and less than or equal to 65536 (you may adjust 'mon max pool pg num' for higher values)

#7 Updated by Dimitri Savineau about 1 month ago

That wasn't the initial issue reported.

What happen if you run "ceph osd pool create foo2 2048" instead ? (assuming you're using filestore).

Also available in: Atom PDF