Project

General

Profile

Bug #42708

mgr/dashboard: Test failure "test_perf_counters_not_found (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest)"

Added by Laura Paduano over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Testing & QA
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

After rebuilding Ceph based on https://github.com/ceph/ceph/pull/31400
and running the dashboard backend API tests locally
I got the following error:

2019-11-07 16:15:49,323.323 INFO:__main__:FAILED (failures=1)
2019-11-07 16:15:49,323.323 INFO:__main__:
2019-11-07 16:15:49,324.324 INFO:__main__:======================================================================
2019-11-07 16:15:49,324.324 INFO:__main__:FAIL: test_perf_counters_not_found (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest)
2019-11-07 16:15:49,324.324 INFO:__main__:----------------------------------------------------------------------
2019-11-07 16:15:49,324.324 INFO:__main__:Traceback (most recent call last):
2019-11-07 16:15:49,325.325 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/test_perf_counters.py", line 73, in test_perf_counters_not_found
2019-11-07 16:15:49,325.325 INFO:__main__:    self.assertSchemaBody(schema)
2019-11-07 16:15:49,325.325 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/helper.py", line 340, in assertSchemaBody
2019-11-07 16:15:49,325.325 INFO:__main__:    self.assertSchema(self.jsonBody(), schema)
2019-11-07 16:15:49,325.325 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/helper.py", line 337, in assertSchema
2019-11-07 16:15:49,326.326 INFO:__main__:    self.assertEqual(data, str(e))
2019-11-07 16:15:49,326.326 INFO:__main__:AssertionError: {u'status': u'404 Not Found', u'detail': u"'osd.4' not found", u'request_id': u'5bf96290-cae7-447d-857e-69856b965a9b'} != "In `input`: missing keys: set(['version', 'traceback'])" 

Also reproducible in Jenkins: https://jenkins.ceph.com/job/ceph-dashboard-pr-backend/456/


Related issues

Related to mgr - Bug #42011: test_perf_counters_mds_get (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest) ... FAIL Duplicate 09/23/2019
Copied to Dashboard - Backport #43054: nautilus: mgr/dashboard: Test failure "test_perf_counters_not_found (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest)" Resolved

History

#1 Updated by Laura Paduano over 4 years ago

  • Related to Bug #42011: test_perf_counters_mds_get (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest) ... FAIL added

#2 Updated by Ernesto Puerta over 4 years ago

This almost due to the Debug mode (as it disables 'version' and 'traceback' from error responses). So, that expectation should be either removed or the debug mode enabled here.

#3 Updated by Ernesto Puerta over 4 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Ernesto Puerta
  • Pull request ID set to 31720

#4 Updated by Laura Paduano about 4 years ago

  • Status changed from Fix Under Review to 7

#5 Updated by Ernesto Puerta about 4 years ago

  • Status changed from 7 to Pending Backport
  • Backport set to nautilus

#6 Updated by Ernesto Puerta about 4 years ago

  • Copied to Backport #43054: nautilus: mgr/dashboard: Test failure "test_perf_counters_not_found (tasks.mgr.dashboard.test_perf_counters.PerfCountersControllerTest)" added

#7 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

#8 Updated by Ernesto Puerta almost 3 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 151 to Testing & QA

Also available in: Atom PDF