Project

General

Profile

Bug #40174

Influx module fails due to missing close() method

Added by Wido den Hollander 4 months ago. Updated 24 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
06/05/2019
Due date:
% Done:

0%

Source:
Tags:
mgr,influx
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The upstream InfluxDBClient has a close() method, but the client supplied by Ubuntu, CentOS and such do not have this version.

We should not call the close() method and let Python handle the Garbage Collection.


Related issues

Copied to mgr - Backport #40904: nautilus: Influx module fails due to missing close() method Resolved

History

#1 Updated by Kefu Chai 3 months ago

  • Status changed from New to Resolved
  • Assignee set to Kefu Chai
  • Pull request ID set to 28427

#2 Updated by Soenke Schippmann about 2 months ago

This bug still exists in Nautilus 14.2.2 - would be great if the fix gets backported.

Thanks,
Sönke

#3 Updated by Nathan Cutler about 2 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to nautilus

#4 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #40904: nautilus: Influx module fails due to missing close() method added

#5 Updated by Nathan Cutler 24 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF