Project

General

Profile

Bug #39972

librados 'buffer::create' and related functions are not exported in C++ API

Added by Jason Dillaman 4 months ago. Updated 28 days ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
05/20/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

Currently, there is no way to create any 'buffer::raw' objects since they are no longer exposed (since Nautilus) via the public API. Move the inline "v14_2_0" namespace up to encompass those methods.


Related issues

Copied to RADOS - Backport #40274: nautilus: librados 'buffer::create' and related functions are not exported in C++ API Resolved

History

#1 Updated by Jason Dillaman 4 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 28167

#2 Updated by Kefu Chai 3 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #40274: nautilus: librados 'buffer::create' and related functions are not exported in C++ API added

#4 Updated by Greg Farnum 28 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF