Project

General

Profile

Bug #39715

client: optimize rename operation under different quota root

Added by Zhi Zhang 6 months ago. Updated 10 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
Start date:
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
ceph-fuse
Labels (FS):
Pull request ID:
Crash signature:

Description

We had many source directories with more than ten millions files. It took very long time to move one such directory to another directory under different quota root, because rename operation was switched to copy and unlink operations, even if the destination directory didn't enable quota or had enough room for source directory.


Related issues

Related to fs - Support #16884: rename() doesn't work between directories Closed 08/01/2016

History

#1 Updated by Zhi Zhang 6 months ago

  • Pull request ID set to 28077

#2 Updated by Patrick Donnelly 6 months ago

  • Related to Support #16884: rename() doesn't work between directories added

#3 Updated by Patrick Donnelly 6 months ago

  • Assignee set to Zhi Zhang
  • Target version set to v15.0.0
  • Start date deleted (05/13/2019)

#4 Updated by Patrick Donnelly 10 days ago

  • Status changed from New to Resolved

Also available in: Atom PDF