Project

General

Profile

Bug #39286

primary recovery local missing object did not update obc

Added by Zengran Zhang 5 months ago. Updated 18 days ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
04/13/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

If not, the snapset in local obc may inconsistent, then the make_writeable()
will make mistakes..


Related issues

Related to RADOS - Bug #41517: Missing head object at primary with snapshots crashes primary Resolved 08/26/2019

History

#1 Updated by Greg Farnum 5 months ago

  • Project changed from Ceph to RADOS

#2 Updated by Neha Ojha 5 months ago

  • Status changed from New to Need Review

#3 Updated by Greg Farnum 5 months ago

  • Pull request ID set to 27575

#4 Updated by Neha Ojha 5 months ago

  • Priority changed from Immediate to High

#5 Updated by Greg Farnum 26 days ago

  • Status changed from Need Review to Pending Backport
  • Backport set to luminous, mimic, nautilus

#9 Updated by Neha Ojha 19 days ago

https://tracker.ceph.com/issues/41517 is a follow on fix for this.

#10 Updated by Nathan Cutler 18 days ago

  • Related to Bug #41517: Missing head object at primary with snapshots crashes primary added

#11 Updated by Nathan Cutler 18 days ago

  • Status changed from Pending Backport to Resolved
  • Backport deleted (luminous, mimic, nautilus)

Since this introduced a regression in master, I propose to refrain from backporting it separately, but instead backport it together with the follow-on fix #41517 - I'm updating that issue to the same effect.

#12 Updated by Nathan Cutler 18 days ago

Backports to luminous, mimic, and nautilus are being handled via #41517

#13 Updated by Nathan Cutler 18 days ago

  • Regression changed from No to Yes

Also available in: Atom PDF