Project

General

Profile

Bug #38631

osd-scrub-repair.sh fails due to num_objects wrong

Added by David Zafman 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
03/07/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

A status check for "1/1 objects unfound" is coming back as "1/2 objects unfound"

Can be reproduced easily with:

./qa/run-standalone.sh "osd-scrub-repair.sh TEST_unfound_erasure_coded_appends"


Related issues

Related to RADOS - Bug #38678: Minor cleanups in tests and log output Resolved 03/11/2019

History

#1 Updated by Sage Weil 6 months ago

  • Status changed from Verified to Resolved

#2 Updated by David Zafman 6 months ago

  • Subject changed from osd-scrub-repair.sh fails due to num_objects wrong to The mon num_objects is off
  • Status changed from Resolved to Verified

Reopening to use for root cause fix. This tracker should also revert 10b9626ea7b.

The commit comment is wrong, because we are using a different EC Pool not the rbd pool.

"..presumably due to the rbd pool init creating the rbd_directory."

#3 Updated by David Zafman 6 months ago

I'm going to remove create_rbd_pool because it isn't used anyway.

#4 Updated by David Zafman 6 months ago

  • Subject changed from The mon num_objects is off to osd-scrub-repair.sh fails due to num_objects wrong
  • Status changed from Verified to Duplicate
  • Pull request ID set to 26899

#5 Updated by David Zafman 6 months ago

  • Related to Bug #38678: Minor cleanups in tests and log output added

#6 Updated by David Zafman 6 months ago

  • Status changed from Duplicate to Resolved

Also available in: Atom PDF