Project

General

Profile

Bug #37964

mgr/dashboard: Test failure: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest)

Added by Laura Paduano almost 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Testing & QA
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When executing the run-backend-api-tests.sh script on my local system I get the following error:

2019-01-18 15:00:13,963.963 INFO:__main__:Running ['./bin/ceph', 'health', '--format=json']
2019-01-18 15:00:14,506.506 INFO:__main__:Running ['./bin/ceph', 'dashboard', 'set-rgw-api-user-id', 'xyz']
2019-01-18 15:00:15,073.073 INFO:tasks.mgr.dashboard.helper:command result: Option RGW_API_USER_ID updated

2019-01-18 15:00:15,074.074 INFO:tasks.mgr.dashboard.helper:Request GET to https://localhost:7789/api/rgw/status
/tmp/tmp.XllFeCx3oV/venv/lib/python2.7/site-packages/urllib3/connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
2019-01-18 15:00:15,087.087 INFO:__main__:test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest) ... FAIL
2019-01-18 15:00:15,087.087 INFO:__main__:Running ['./bin/ceph', 'log', 'Ended test tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest.test_invalid_user_id']
2019-01-18 15:00:16,628.628 INFO:__main__:Stopped test: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest) in 16.825128s
2019-01-18 15:00:16,629.629 INFO:__main__:
2019-01-18 15:00:16,629.629 INFO:__main__:======================================================================
2019-01-18 15:00:16,629.629 INFO:__main__:FAIL: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest)
2019-01-18 15:00:16,629.629 INFO:__main__:----------------------------------------------------------------------
2019-01-18 15:00:16,629.629 INFO:__main__:Traceback (most recent call last):
2019-01-18 15:00:16,630.630 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/test_rgw.py", line 119, in test_invalid_user_id
2019-01-18 15:00:16,630.630 INFO:__main__:    data['message'])
2019-01-18 15:00:16,630.630 INFO:__main__:AssertionError: 'The user "xyz" is unknown to the Object Gateway.' not found in u'No RGW found'
2019-01-18 15:00:16,630.630 INFO:__main__:
2019-01-18 15:00:16,630.630 INFO:__main__:----------------------------------------------------------------------
2019-01-18 15:00:16,631.631 INFO:__main__:Ran 107 tests in 1151.338s
2019-01-18 15:00:16,631.631 INFO:__main__:
2019-01-18 15:00:16,631.631 INFO:__main__:FAILED (failures=1, skipped=1)
2019-01-18 15:00:16,631.631 INFO:__main__:
2019-01-18 15:00:16,631.631 INFO:__main__:======================================================================
2019-01-18 15:00:16,632.632 INFO:__main__:FAIL: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest)
2019-01-18 15:00:16,632.632 INFO:__main__:----------------------------------------------------------------------
2019-01-18 15:00:16,632.632 INFO:__main__:Traceback (most recent call last):
2019-01-18 15:00:16,632.632 INFO:__main__:  File "/ceph/qa/tasks/mgr/dashboard/test_rgw.py", line 119, in test_invalid_user_id
2019-01-18 15:00:16,632.632 INFO:__main__:    data['message'])
2019-01-18 15:00:16,632.632 INFO:__main__:AssertionError: 'The user "xyz" is unknown to the Object Gateway.' not found in u'No RGW found'


Related issues

Copied to Dashboard - Bug #42959: mgr/dashboard: Test failure: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest) Can't reproduce

History

#1 Updated by Laura Paduano almost 4 years ago

Edit: Haven't seen those errors when running the Teuthology tests so far.

#2 Updated by Laura Paduano almost 4 years ago

  • Status changed from New to Resolved
  • Assignee set to Alfonso Martínez
  • Pull request ID set to 26172

#3 Updated by Neha Ojha about 3 years ago

This looks like a similar issue on recent master, should we reopen this or create a new issue?

2019-11-20T21:10:56.289 INFO:tasks.cephfs_test_runner:======================================================================
2019-11-20T21:10:56.289 INFO:tasks.cephfs_test_runner:FAIL: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest)
2019-11-20T21:10:56.289 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-11-20T21:10:56.289 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-11-20T21:10:56.289 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_fix-merge-vs-backoff/qa/tasks/mgr/dashboard/test_rgw.py", line 105, in test_invalid_user_id
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:    data['message'])
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:AssertionError: 'The user "xyz" is unknown to the Object Gateway.' not found in u'No RGW found'
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:Ran 137 tests in 1307.860s
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:
2019-11-20T21:10:56.290 INFO:tasks.cephfs_test_runner:FAILED (failures=1)
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:======================================================================
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:FAIL: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest)
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_fix-merge-vs-backoff/qa/tasks/mgr/dashboard/test_rgw.py", line 105, in test_invalid_user_id
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:    data['message'])
2019-11-20T21:10:56.291 INFO:tasks.cephfs_test_runner:AssertionError: 'The user "xyz" is unknown to the Object Gateway.' not found in u'No RGW found'

/a/nojha-2019-11-20_19:52:21-rados-fix-merge-vs-backoff-distro-basic-smithi/4525899/

#4 Updated by Alfonso Martínez about 3 years ago

There is this PR that aims to fix some API tests:
https://github.com/ceph/ceph/pull/31484

#5 Updated by Laura Paduano about 3 years ago

  • Copied to Bug #42959: mgr/dashboard: Test failure: test_invalid_user_id (tasks.mgr.dashboard.test_rgw.RgwApiCredentialsTest) added

#6 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 151 to Testing & QA

Also available in: Atom PDF