Project

General

Profile

Bug #37516

mds: remove duplicated l_mdc_num_strays perfcounter set

Added by Zhi Zhang 12 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
Start date:
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature:

Description

The l_mdc_num_strays perfcounter had been encapsulated into StrayManager notify_stray_created() and notify_stray_removed(). So remove the duplicated one from _purge_stray_purged() because it was set via dn->push_projected_linkage().


Related issues

Copied to fs - Backport #37632: mimic: mds: remove duplicated l_mdc_num_strays perfcounter set Resolved
Copied to fs - Backport #37633: luminous: mds: remove duplicated l_mdc_num_strays perfcounter set Resolved

History

#1 Updated by Patrick Donnelly 11 months ago

  • Status changed from New to Need Review
  • Assignee set to Zhi Zhang
  • Target version set to v14.0.0
  • Start date deleted (12/04/2018)
  • Backport set to mimic,luminous
  • Pull request ID set to 25389

#2 Updated by Patrick Donnelly 11 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #37632: mimic: mds: remove duplicated l_mdc_num_strays perfcounter set added

#4 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #37633: luminous: mds: remove duplicated l_mdc_num_strays perfcounter set added

#5 Updated by Patrick Donnelly 10 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF