Project

General

Profile

Bug #37292

RDMAStack - poll failed error when using IB and RDMACM

Added by Stig Telfer 9 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/16/2018
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
RDMA
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:

Description

The error message "polling - poll failed" occurs because interrupted system calls are not handled in method RDMADispatcher::polling. This appears to happen regularly in a configuration using Infiniband and RDMACM.


Related issues

Duplicated by Messengers - Bug #38392: msg/async: the poll needs to retry when it is interrupted by signal Duplicate 02/20/2019

History

#1 Updated by Kefu Chai 6 months ago

  • Duplicated by Bug #38392: msg/async: the poll needs to retry when it is interrupted by signal added

#2 Updated by Kefu Chai 6 months ago

  • Status changed from New to Need Review
  • Assignee set to Stig Telfer
  • Target version deleted (v14.0.0)
  • Pull request ID set to 25138

#3 Updated by Kefu Chai 6 months ago

  • Status changed from Need Review to Resolved

#4 Updated by Greg Farnum 5 months ago

  • Project changed from Ceph to Messengers
  • Category deleted (msgr)

Also available in: Atom PDF