Project

General

Profile

Bug #36668

client: request next osdmap for blacklisted client

Added by Zhi Zhang 11 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
Start date:
11/01/2018
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client
Labels (FS):
Pull request ID:

Description

In Luminous version, we found blacklisted client would never get rid of blacklisted flag if network was down for some time and MDS evicted this client session after timeout.

Here are some simple steps to reproduce:
1. Add a client to blacklist via "ceph osd blacklist add" command.
2. Wait for session timeout, MDS will evict this client session and then client will close its MDS session too.
3. Remove this client from blacklist via "ceph osd blacklist [rm|clear]" command.

Now there is no blacklisted entry, but this client's blacklisted flag is still true, so client is still not working.

The root cause is that when client became blacklisted, it did't subscribe next osdmap. So when it was removed from blacklist by expiration or commandline, it didn't get updated osdmap which is the only way for the client to reset its blacklisted flag.


Related issues

Copied to fs - Backport #36690: mimic: client: request next osdmap for blacklisted client Resolved
Copied to fs - Backport #36691: luminous: client: request next osdmap for blacklisted client Resolved

History

#2 Updated by Patrick Donnelly 11 months ago

  • Status changed from New to Need Review
  • Assignee set to Zhi Zhang
  • Target version set to v14.0.0
  • Backport set to mimic,luminous
  • Component(FS) Client added
  • Component(FS) deleted (ceph-fuse)

#3 Updated by Patrick Donnelly 11 months ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #36690: mimic: client: request next osdmap for blacklisted client added

#5 Updated by Nathan Cutler 11 months ago

  • Copied to Backport #36691: luminous: client: request next osdmap for blacklisted client added

#6 Updated by Patrick Donnelly 8 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF