Project

General

Profile

Bug #36632

mgr/dashboard:update Python dependency

Added by Alfonso Martínez about 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Category:
General - Back-end
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

We received a Github security warning regarding the following file:

https://github.com/ceph/ceph/blob/master/src/pybind/mgr/dashboard/requirements.txt

Known moderate severity security vulnerability detected in
requests <= 2.19.1 defined in requirements.txt.
requirements.txt update suggested: requests ~> 2.20.0.

We should update the dependency accordingly.

History

#1 Updated by Volker Theile about 4 years ago

  • Category set to 146
  • Target version set to v14.0.0
  • Source set to Development

#2 Updated by Alfonso Martínez about 4 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Alfonso Martínez

#4 Updated by Alfonso Martínez about 4 years ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Ernesto Puerta over 1 year ago

  • Tracker changed from Fix to Bug
  • Project changed from mgr to Dashboard
  • Category changed from 146 to General - Back-end
  • Regression set to No
  • Severity set to 3 - minor

Also available in: Atom PDF