Project

General

Profile

Bug #25139

Task wrapper should not call notifyTask if a task fails

Added by Stephan Müller about 3 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Category:
General
Target version:
% Done:

100%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Task wrapper should not call notifyTask if a task fails as this is done by the API interceptor, because of this you often get two error messages shown.


Related issues

Duplicated by Dashboard - Bug #25092: mgr/dashboard: RBD error messages are displayed twice Duplicate

History

#1 Updated by Ricardo Marques about 3 years ago

Apparently this is a duplicate of https://tracker.ceph.com/issues/25092

#2 Updated by Ricardo Marques about 3 years ago

  • Duplicated by Bug #25092: mgr/dashboard: RBD error messages are displayed twice added

#3 Updated by Stephan Müller about 3 years ago

  • Status changed from In Progress to Resolved

#4 Updated by Ernesto Puerta 5 months ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General

Also available in: Atom PDF