Project

General

Profile

Actions

Bug #25068

closed

mgr/dashboard: RGW is not working if an URL prefix is defined

Added by Ricardo Marques over 5 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Component - RGW
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If we define an URL prefix as described in the documentation1, RGW pages will not working.

The RGW frontend api services should be adapted to use the "api/..." URL instead of "/api/...", because URLs starting with `/` will ignore the URL prefix.

[1] http://docs.ceph.com/docs/mimic/mgr/dashboard/#reverse-proxies

Actions #1

Updated by John Spray over 5 years ago

  • Subject changed from mgr/dashboard: RGW is now working if an URL prefix is defined to mgr/dashboard: RGW is not working if an URL prefix is defined
Actions #2

Updated by Volker Theile over 5 years ago

  • Assignee set to Volker Theile
Actions #3

Updated by Volker Theile over 5 years ago

  • Status changed from New to Fix Under Review
Actions #5

Updated by Volker Theile over 5 years ago

  • Target version set to v14.0.0
  • Source set to Development
  • Affected Versions v14.0.0 added
Actions #6

Updated by Volker Theile over 5 years ago

  • Affected Versions v13.2.1 added
Actions #7

Updated by Nathan Cutler over 5 years ago

OK. Please don't fill in the "Backport" field on this tracker. Thanks!

Actions #8

Updated by Yuri Weinstein over 5 years ago

Volker Theile wrote:

PR for Mimic: https://github.com/ceph/ceph/pull/23203

merged

Actions #9

Updated by Nathan Cutler over 5 years ago

  • Status changed from Fix Under Review to Resolved
Actions #10

Updated by Ernesto Puerta about 3 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 143 to Component - RGW
Actions

Also available in: Atom PDF