Project

General

Profile

Bug #2390

dencoder: depends on expat

Added by Yehuda Sadeh almost 12 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

dencoder uses rgw_dencoder.cc which requires the expat library.

History

#1 Updated by Sage Weil almost 12 years ago

  • Target version set to v0.47

#2 Updated by Sage Weil almost 12 years ago

Hmm, ideally ceph-dencoder would still understand the types but not need expat to compile. Which is shouldn't, in principle.. maybe #ifdef out the expat bits if rgw itself isn't enabled? or HAVE_EXPAT isn't defined or something like that?

#3 Updated by Sage Weil over 11 years ago

  • Target version deleted (v0.47)

#4 Updated by Sage Weil almost 11 years ago

  • Status changed from New to Won't Fix

not sure this is worth fixing or worrying about.

#5 Updated by David Disseldorp about 8 years ago

I plan on submitting a fix for the (currently broken) Expat dependency checking:
- Check for Expat regardless of rgw build settings, as it's needed for dencoder
- Check for the expat.h header file, rather than just the runtime dependency

Could someone please reopen this bug? It looks like I don't have permission to do so.

#6 Updated by Nathan Cutler about 8 years ago

  • Status changed from Won't Fix to In Progress

#7 Updated by David Disseldorp about 8 years ago

David Disseldorp wrote:

I plan on submitting a fix for the (currently broken) Expat dependency checking:
- Check for Expat regardless of rgw build settings, as it's needed for dencoder

Fix submitted via:
https://github.com/ceph/ceph/pull/6772

#8 Updated by Nathan Cutler about 8 years ago

  • Status changed from In Progress to Fix Under Review

#9 Updated by David Disseldorp about 8 years ago

This was fixed via:
https://github.com/ceph/ceph/pull/7476

This bug can be closed.

#10 Updated by Nathan Cutler about 8 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF