Project

General

Profile

Bug #23496

ceph-volume: lsblk: unknown column: PKNAME,PARTLABEL

Added by Robin Johnson over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

(i'm going to open a separate bug for the --yes failure).

Running Luminous 12.2.4++ on Ubuntu Trusty 14.0.4.5

root@cephstore12145:/# ceph-volume lvm create --filestore --journal /dev/nvme0n1p65 --data /dev/sde --dmcrypt
Running command: ceph-authtool --gen-print-key
Running command: ceph-authtool --gen-print-key
Running command: ceph --cluster ceph --name client.bootstrap-osd --keyring /var/lib/ceph/bootstrap-osd/ceph.keyring -i - osd new 8678d0e2-fddc-4103-9141-bf8a92aee973
stderr: lsblk: unknown column: PKNAME,PARTLABEL
stderr: lsblk: unknown column: PKNAME,PARTLABEL
Running command: vgcreate --force --yes ceph-7edc3c91-1c72-4e87-8a47-af786c2c78ef /dev/sde
stderr: No physical volume label read from /dev/sde
stdout: Physical volume "/dev/sde" successfully created
stdout: Volume group "ceph-7edc3c91-1c72-4e87-8a47-af786c2c78ef" successfully created
Running command: lvcreate --yes -l 100%FREE -n osd-data-8678d0e2-fddc-4103-9141-bf8a92aee973 ceph-7edc3c91-1c72-4e87-8a47-af786c2c78ef
stderr: lvcreate: unrecognized option '--yes'
Error during parsing of command line.
--> Was unable to complete a new OSD, will rollback changes
--> OSD will be fully purged from the cluster, because the ID was generated
Running command: ceph osd purge osd.110 --yes-i-really-mean-it
stderr: purged osd.110
--> RuntimeError: command returned non-zero exit status: 3

History

#1 Updated by Alfredo Deza over 4 years ago

  • Status changed from New to Closed

This is because PKNAME and PARTLABEL were not part of lsblk in Trusty

ceph-volume does not support Trusty

Same as issue #23497, we somehow missed the window to add a warning on this (for Trusty users)

Also available in: Atom PDF