Project

General

Profile

Backport #22703

jewel: rgw: offline resharding doesn't seem to preserve bucket acls

Added by Abhishek Lekshmanan about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Release:
jewel
Crash signature (v1):
Crash signature (v2):


Related issues

Copied from rgw - Bug #22742: rgw: resharding doesn't seem to preserve bucket acls Resolved

History

#1 Updated by Orit Wasserman about 5 years ago

  • Assignee set to Orit Wasserman

#2 Updated by Orit Wasserman about 5 years ago

  • Backport set to luminous

#3 Updated by Orit Wasserman about 5 years ago

  • Backport changed from luminous to luminous, jewel

#4 Updated by Orit Wasserman about 5 years ago

I was successful in reproducing in master

#5 Updated by Orit Wasserman about 5 years ago

  • Status changed from New to In Progress

#6 Updated by Orit Wasserman about 5 years ago

  • Copied to Bug #22742: rgw: resharding doesn't seem to preserve bucket acls added

#7 Updated by Orit Wasserman about 5 years ago

  • Priority changed from Normal to High

#8 Updated by Orit Wasserman about 5 years ago

  • Subject changed from rgw: offline resharding doesn't seem to preserve bucket acls to jewel: rgw: offline resharding doesn't seem to preserve bucket acls
  • Backport changed from luminous, jewel to jewel
  • Release set to jewel

#9 Updated by Orit Wasserman about 5 years ago

  • Status changed from In Progress to Fix Under Review

#10 Updated by Nathan Cutler about 5 years ago

  • Backport changed from jewel to jewel luminous

#11 Updated by Nathan Cutler about 5 years ago

  • Subject changed from jewel: rgw: offline resharding doesn't seem to preserve bucket acls to rgw: offline resharding doesn't seem to preserve bucket acls

#12 Updated by Nathan Cutler about 5 years ago

  • Status changed from Fix Under Review to New

This ticket is for the master fix, but I don't see a master PR?

Master PR: https://github.com/ceph/ceph/pull/20037 (closed)

#13 Updated by Nathan Cutler about 5 years ago

I'm guessing this can be closed because the master PR was closed and a jewel-only fix was proposed.

#14 Updated by Nathan Cutler about 5 years ago

  • Backport changed from jewel luminous to jewel

#15 Updated by Nathan Cutler about 5 years ago

  • Copied to deleted (Bug #22742: rgw: resharding doesn't seem to preserve bucket acls)

#16 Updated by Nathan Cutler about 5 years ago

  • Copied from Bug #22742: rgw: resharding doesn't seem to preserve bucket acls added

#17 Updated by Nathan Cutler about 5 years ago

  • Description updated (diff)

#18 Updated by Nathan Cutler about 5 years ago

  • Tracker changed from Bug to Backport
  • Description updated (diff)
  • Status changed from New to In Progress

#19 Updated by Nathan Cutler about 5 years ago

  • Subject changed from rgw: offline resharding doesn't seem to preserve bucket acls to jewel: rgw: offline resharding doesn't seem to preserve bucket acls

#20 Updated by Nathan Cutler almost 5 years ago

  • Priority changed from High to Normal

#21 Updated by Nathan Cutler almost 5 years ago

  • Status changed from In Progress to Resolved
  • Target version set to v10.2.11

Also available in: Atom PDF