Project

General

Profile

Bug #2095

osd: need feature bit for v0.42 osdmap encoding change

Added by Sage Weil about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Associated revisions

Revision ddc99983 (diff)
Added by Greg Farnum about 8 years ago

osd: conditionally encode old pg_pool_t when no CEPH_FEATURE_OSDENC

This fixes OSDMap compatibility between v0.42 and <v0.42.

For MOSDMap, reencode maps if OSDENC feature is missing. Also rev the
message version. We don't use COMPAT version here because v3 can't be
understood by v2 (that's why we're checking feature bits). (It will be
possible to do that later when our constituent types can be decoded by
multiple versions.)

Fixes: #2095
Signed-off-by: Sage Weil <>
Reviewed-by: Greg Farnum <>

History

#1 Updated by Sage Weil about 8 years ago

  • Assignee set to Sage Weil

#2 Updated by Sage Weil about 8 years ago

  • Status changed from New to 4

we had a feature bit already, we just needed to conditonally encodee the old format, and tweak MOSDMap to reencode maps that way. tested against v0.41 and it fixes the problem. wip-pgpool

#3 Updated by Sage Weil about 8 years ago

  • Status changed from 4 to Resolved

Also available in: Atom PDF