Project

General

Profile

Bug #19019

multisite: RGWMetaSyncShardControlCR gives up on EIO

Added by Casey Bodley almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Testing of multisite sync while the master zone is stopping OSDs was seen to cause several errors of the form:

2017-02-18 17:42:24.218667 7f36baffd700  0 rgw meta sync: ERROR: RGWBackoffControlCR called coroutine returned -5

Because RGWMetaSyncShardControlCR uses RGWBackoffControlCR with exit_on_error=true, it gives up on EIO errors and no further sync is possible on that mdlog shard.


Related issues

Copied to rgw - Backport #19159: jewel: multisite: RGWMetaSyncShardControlCR gives up on EIO Resolved
Copied to rgw - Backport #19160: kraken: multisite: RGWMetaSyncShardControlCR gives up on EIO Resolved

History

#1 Updated by Casey Bodley almost 6 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Casey Bodley almost 6 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler almost 6 years ago

  • Copied to Backport #19159: jewel: multisite: RGWMetaSyncShardControlCR gives up on EIO added

#4 Updated by Nathan Cutler almost 6 years ago

  • Copied to Backport #19160: kraken: multisite: RGWMetaSyncShardControlCR gives up on EIO added

#5 Updated by Nathan Cutler over 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF