Project

General

Profile

Bug #18446

osd: filestore: FALLOC_FL_PUNCH_HOLE must be used with FALLOC_FL_KEEP_SIZE

Added by Yao Ning almost 6 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
-
% Done:

100%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

_zero() in filestore always return -EOPNOTSUPP if there is no flags FALLOC_FL_KEEP_SIZE.


Related issues

Copied to Ceph - Backport #18448: hammer: osd: filestore: FALLOC_FL_PUNCH_HOLE must be used with FALLOC_FL_KEEP_SIZE Resolved

History

#1 Updated by Yao Ning almost 6 years ago

Already fixed in master, and I think we need backport to hammer since it is a trivial backport.

https://github.com/ceph/ceph/pull/7768

#2 Updated by Yao Ning almost 6 years ago

#3 Updated by Nathan Cutler almost 6 years ago

  • Status changed from New to Pending Backport
  • Backport set to hammer

#4 Updated by Nathan Cutler almost 6 years ago

  • Copied to Backport #18448: hammer: osd: filestore: FALLOC_FL_PUNCH_HOLE must be used with FALLOC_FL_KEEP_SIZE added

#5 Updated by Nathan Cutler almost 6 years ago

  • Target version deleted (v0.94.10)

#6 Updated by Nathan Cutler almost 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF