Project

General

Profile

Bug #17267

run-tox.sh hides errors

Added by Dan Mick almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

run-tox.sh runs the check tests for several python tools. It runs tox with stdout and stdout redirected to <virtualenv>/tox.out, and greps the result for "InterpreterNotFound". Sadly, if that's the error (say, running on a host with no python3.4 installed), there's no indication to the test run of the failure reason, because it's only held in tox.out.

Guess who spent days trying to track this down?

History

#1 Updated by Dan Mick almost 4 years ago

Argh. If it had even been "grep" as opposed to "grep -v" I would have seen this error.
As it is, I don't see any reason not to show stderr and stdout, even if they are being captured.

#2 Updated by Dan Mick almost 4 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Dan Mick

#4 Updated by Dan Mick almost 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF