Project

General

Profile

Bug #1722

osd_class_dir must reflect autoconf libdir

Added by Anonymous over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

These two end up at different values for systems using /usr/lib64:

src/common/config_opts.h:285:OPTION
src/Makefile.am:392:radoslibdir = $(libdir)/rados-classes


Related issues

Duplicated by Ceph - Bug #1614: default rados class location needs to be depend on autoconf libdir Duplicate 10/12/2011

Associated revisions

Revision 85719b0e (diff)
Added by Sage Weil over 8 years ago

config: use autoconf $libdir for default rados class dir

Fixes: #1722
Signed-off-by: Sage Weil <>

History

#1 Updated by Anonymous over 8 years ago

See also #1614, which for some reason doesn't let me edit it anymore.

#2 Updated by Sage Weil over 8 years ago

the original commit is 7e5dee907a8218647a88d1c7d3316cc277e1c44b. iirc that approach didn't work because automake wasn't detecting the dependency of config_opts.h on aclocations.h

#3 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position set to 1

#4 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position deleted (11)
  • translation missing: en.field_position set to 1

#5 Updated by Sage Weil over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF