Project

General

Profile

Bug #1657

teuthology: testrados failed to find conf

Added by Josh Durgin almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
teuthology
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

From teuthology:~teuthworker/archive/nightly_coverage_2011-10-26/1037/teuthology.log:

2011-10-26T17:19:49.364 INFO:teuthology.run_tasks:Running task testrados...
2011-10-26T17:19:49.418 INFO:teuthology.task.testrados:Beginning testrados...
2011-10-26T17:19:49.419 DEBUG:teuthology.orchestra.run:Running: 'cp /tmp/cephtest/ceph.conf /tmp/cephtest/data/ceph.conf'
2011-10-26T17:19:49.420 INFO:teuthology.task.thrashosds.thrasher:starting do_thrash
2011-10-26T17:19:49.420 INFO:teuthology.task.thrashosds.thrasher:in_osds:  [0, 1, 2, 3, 4, 5, 6, 7]  out_osds:  [] dead_osds:  [] live_osds:  [1, 0, 3, 2, 5, 4, 7, 6]
2011-10-26T17:19:49.420 INFO:teuthology.task.thrashosds.thrasher:Removing osd 7, in_osds are: [0, 1, 2, 3, 4, 5, 6, 7]
2011-10-26T17:19:49.421 DEBUG:teuthology.orchestra.run:Running: 'LD_LIBRARY_PRELOAD=/tmp/cephtest/binary/usr/local/lib /tmp/cephtest/enable-coredump /tmp/cephtest/binary/usr/local/bin/ceph-coverage /tmp/cephtest/archive/coverage /tmp/cephtest/binary/usr/local/bin/ceph -k /tmp/cephtest/ceph.keyring -c /tmp/cephtest/ceph.conf --concise osd out 7'
2011-10-26T17:19:49.436 DEBUG:teuthology.orchestra.run:Running: "/bin/sh -c 'cd /tmp/cephtest/data; export CEPH_CLIENT_ID=0; LD_PRELOAD=/tmp/cephtest/binary/usr/local/lib/librados.so.2 /tmp/cephtest/binary/usr/local/bin/testsnaps 4000 500 16'" 
2011-10-26T17:19:49.492 DEBUG:teuthology.run_tasks:Unwinding manager <contextlib.GeneratorContextManager object at 0x2ae55d0>
2011-10-26T17:19:49.493 DEBUG:teuthology.orchestra.run:Running: 'rm /tmp/cephtest/data/ceph.conf'
2011-10-26T17:19:49.499 INFO:teuthology.task.testrados:joining testrados
2011-10-26T17:19:49.505 INFO:teuthology.task.testrados.testrados.0.err:Client id is: 0
2011-10-26T17:19:49.505 INFO:teuthology.task.testrados.testrados.0.err:unable to find any monitors in conf. please specify monitors via -m monaddr or -c ceph.conf
2011-10-26T17:19:49.506 INFO:teuthology.task.testrados.testrados.0.out:Writing initial 1
2011-10-26T17:19:49.507 INFO:teuthology.task.testrados.testrados.0.err:Segmentation fault
2011-10-26T17:19:49.507 ERROR:teuthology.run_tasks:Manager failed: <contextlib.GeneratorContextManager object at 0x2ae55d0>
Traceback (most recent call last):
  File "/var/lib/teuthworker/teuthology/teuthology/run_tasks.py", line 45, in run_tasks
    suppress = manager.__exit__(*exc_info)
  File "/usr/lib/python2.6/contextlib.py", line 23, in __exit__
    self.gen.next()
  File "/var/lib/teuthworker/teuthology/teuthology/task/testrados.py", line 103, in task
    run.wait(testrados.itervalues())
  File "/var/lib/teuthworker/teuthology/teuthology/orchestra/run.py", line 272, in wait
    proc.exitstatus.get()
  File "/var/lib/teuthworker/teuthology/virtualenv/lib/python2.6/site-packages/gevent/event.py", line 223, in get
    raise self._exception
CommandFailedError: Command failed with status 139: "/bin/sh -c 'cd /tmp/cephtest/data; export CEPH_CLIENT_ID=0; LD_PRELOAD=/tmp/cephtest/binary/usr/local/lib/librados.so.2 /tmp/cephtest/binary/usr/local/bin/testsnaps 4000 500 16'" 

History

#1 Updated by Josh Durgin almost 10 years ago

  • Description updated (diff)
  • Category set to teuthology
  • Target version set to v0.38

#2 Updated by Sage Weil almost 10 years ago

  • Target version changed from v0.38 to v0.39

#3 Updated by Sage Weil almost 10 years ago

  • translation missing: en.field_position set to 92

#4 Updated by Samuel Just almost 10 years ago

  • Assignee set to Samuel Just

#5 Updated by Samuel Just almost 10 years ago

  • Status changed from New to Resolved

Should work now

ceph: 1d9e8065c835c343608930585c2853984cde2fa8
teuthology: 810cae1a1d03138abfa54cd31059723ec0c22ab1

#6 Updated by Josh Durgin over 9 years ago

  • Status changed from Resolved to New

Failed due to escaped env setting:

2011-11-02T04:01:46.174 INFO:teuthology.task.testrados.testrados.0.err:bash: CEPH_CLIENT_ID=0;: command not found
2011-11-02T04:01:46.174 ERROR:teuthology.run_tasks:Manager failed: <contextlib.GeneratorContextManager object at 0x1f6bc10>
Traceback (most recent call last):
  File "/var/lib/teuthworker/teuthology/teuthology/run_tasks.py", line 45, in run_tasks
    suppress = manager.__exit__(*exc_info)
  File "/usr/lib/python2.6/contextlib.py", line 23, in __exit__
    self.gen.next()
  File "/var/lib/teuthworker/teuthology/teuthology/task/testrados.py", line 84, in task
    run.wait(testrados.itervalues())
  File "/var/lib/teuthworker/teuthology/teuthology/orchestra/run.py", line 272, in wait
    proc.exitstatus.get()
  File "/var/lib/teuthworker/teuthology/virtualenv/lib/python2.6/site-packages/gevent/event.py", line 223, in get
    raise self._exception
CommandFailedError: Command failed with status 127: "'CEPH_CLIENT_ID=0;' CEPH_CONF=/tmp/cephtest/ceph.conf LD_PRELOAD=/tmp/cephtest/binary/usr/local/lib/librados.so.2 /tmp/cephtest/binary/usr/local/bin/testreadwrite 4000 500 50 16" 

#7 Updated by Samuel Just over 9 years ago

  • Status changed from New to Resolved

Forgot to include my fix for that, pushed: a2f406ef49a1e5ec31d90957122e14addf56901c.

Also available in: Atom PDF