Project

General

Profile

Bug #15166

broken sudoers file?

Added by Greg Farnum over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Infrastructure Service
Target version:
-
Start date:
03/17/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://qa-proxy.ceph.com/teuthology/gregf-2016-03-16_13:01:47-fs-greg-fs-testing-316---basic-mira/66399/

2016-03-16T13:12:44.509 INFO:teuthology.orchestra.run.mira034:Running: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage ceph mds fail a'
2016-03-16T13:12:44.510 INFO:teuthology.orchestra.run.mira034:Running: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage ceph mds fail b'
2016-03-16T13:12:44.603 INFO:teuthology.orchestra.run.mira034.stderr:sudo: >>> /etc/sudoers: syntax error near line 47 <<<
2016-03-16T13:12:44.603 INFO:teuthology.orchestra.run.mira034.stderr:sudo: parse error in /etc/sudoers near line 47
2016-03-16T13:12:44.603 INFO:teuthology.orchestra.run.mira034.stderr:sudo: >>> /etc/sudoers: syntax error near line 47 <<<
2016-03-16T13:12:44.604 INFO:teuthology.orchestra.run.mira034.stderr:sudo: parse error in /etc/sudoers near line 47
2016-03-16T13:12:44.605 INFO:teuthology.orchestra.run.mira034.stderr:sudo: no valid sudoers sources found, quitting
2016-03-16T13:12:44.605 INFO:teuthology.orchestra.run.mira034.stderr:sudo: no valid sudoers sources found, quitting
2016-03-16T13:12:44.616 INFO:teuthology.orchestra.run.mira034.stderr:sudo: unable to initialize policy plugin
2016-03-16T13:12:44.617 INFO:teuthology.orchestra.run.mira034.stderr:sudo: unable to initialize policy plugin

There are some invocations of "sudo" in the log earlier on that didn't fail, but it's intermittently reporting that "syntax error near line 47". I logged in to mira034 and it seems to be working now; line 47 is "#includedir /etc/sudoers.d", which seems correct?

History

#1 Updated by Greg Farnum over 3 years ago

So, yeah, this is basically an archival ticket as it seems to be working now. But in case it comes up again, here's one recording the problem. (Please move if it should be in teuthology or something; I'm not quite sure.)

#2 Updated by David Galloway over 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF