Project

General

Profile

Bug #14759

ovh: failed snaptest-git-ceph.sh test

Added by Greg Farnum over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/14/2016
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client
Labels (FS):
Pull request ID:

Description

http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-02-06_18:04:02-fs-master---basic-openstack/17910/

Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 82, in __exit__
    for result in self:
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 101, in next
    resurrect_traceback(result)
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 19, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/ceph-qa-suite_master/tasks/workunit.py", line 385, in _run_tests
    label="workunit test {workunit}".format(workunit=workunit)
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/remote.py", line 156, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 378, in run
    r.wait()
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 114, in wait
    label=self.label)
CommandFailedError: Command failed (workunit test fs/snaps/snaptest-git-ceph.sh) on target077028 with status 1: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=7f854cc1800afad51596e42313a2a8bfd69e5546 TESTDIR="/home/ubuntu/cephtest" CEPH_ID="0" PATH=$PATH:/usr/sbin adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 3h /home/ubuntu/cephtest/workunit.client.0/fs/snaps/snaptest-git-ceph.sh'

as a result of

2016-02-06T23:30:57.807 INFO:tasks.workunit.client.0.target077028.stderr:+ echo checking v0.12
2016-02-06T23:30:57.807 INFO:tasks.workunit.client.0.target077028.stderr:+ cd .snap/v0.12
2016-02-06T23:30:57.808 INFO:tasks.workunit.client.0.target077028.stderr:+ git diff --exit-code
2016-02-06T23:31:03.366 INFO:tasks.workunit.client.0.target077028.stdout:diff --git a/src/include/librados.h b/src/include/librados.h
2016-02-06T23:31:03.369 INFO:tasks.workunit.client.0.target077028.stdout:index 00360f3..e69de29 100644
2016-02-06T23:31:03.369 INFO:tasks.workunit.client.0.target077028.stdout:--- a/src/include/librados.h
2016-02-06T23:31:03.369 INFO:tasks.workunit.client.0.target077028.stdout:+++ b/src/include/librados.h
2016-02-06T23:31:03.369 INFO:tasks.workunit.client.0.target077028.stdout:@@ -1,146 +0,0 @@
2016-02-06T23:31:03.370 INFO:tasks.workunit.client.0.target077028.stdout:-#ifndef __LIBRADOS_H
2016-02-06T23:31:03.370 INFO:tasks.workunit.client.0.target077028.stdout:-#define __LIBRADOS_H
2016-02-06T23:31:03.370 INFO:tasks.workunit.client.0.target077028.stdout:-
...

I wouldn't be surprised if this were the result of an infrastructure failure, though, so leaving it at normal priority.

History

#1 Updated by Zheng Yan over 3 years ago

might be duplicate of #10436

#2 Updated by Greg Farnum over 3 years ago

  • Status changed from New to Closed

It hasn't popped up again.

#3 Updated by Greg Farnum about 3 years ago

  • Component(FS) Client added

Also available in: Atom PDF