Project

General

Profile

Bug #14639

failing gitbuilder connections from mira (DNS lookup errors)

Added by Greg Farnum over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Category:
Infrastructure Service
Target version:
-
Start date:
02/04/2016
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4628/

2016-02-03T12:39:54.023 INFO:teuthology.packaging:Looking for package version: http://gitbuilder.ceph.com/ceph-deb-trusty-x86_64-basic/sha1/4daa934e6d2d50754149a876fb8bf5cef1f6c71d/version
2016-02-03T12:40:04.101 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 53, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 41, in run_one_task
    return fn(**kwargs)
  File "/home/teuthworker/src/teuthology_master/teuthology/task/internal.py", line 267, in check_packages
    if package.version:
  File "/home/teuthworker/src/teuthology_master/teuthology/packaging.py", line 536, in version
    self._version = self._get_package_version()
  File "/home/teuthworker/src/teuthology_master/teuthology/packaging.py", line 718, in _get_package_version
    resp = _get_response(url, wait=self.job_config.get("wait_for_package", False))
  File "/home/teuthworker/src/teuthology_master/teuthology/packaging.py", line 430, in _get_response
    resp = requests.get(url)
  File "/home/teuthworker/src/teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/api.py", line 67, in get
    return request('get', url, params=params, **kwargs)
  File "/home/teuthworker/src/teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/api.py", line 53, in request
    return session.request(method=method, url=url, **kwargs)
  File "/home/teuthworker/src/teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/sessions.py", line 468, in request
    resp = self.send(prep, **send_kwargs)
  File "/home/teuthworker/src/teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/sessions.py", line 576, in send
    r = adapter.send(request, **kwargs)
  File "/home/teuthworker/src/teuthology_master/virtualenv/local/lib/python2.7/site-packages/requests/adapters.py", line 437, in send
    raise ConnectionError(e, request=request)
ConnectionError: HTTPConnectionPool(host='gitbuilder.ceph.com', port=80): Max retries exceeded with url: /ceph-deb-trusty-x86_64-basic/sha1/4daa934e6d2d50754149a876fb8bf5cef1f6c71d/version (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f341896fb10>: Failed to establish a new connection: [Errno -2] Name or service not known',))

http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4595/
http://pulpito.ceph.com/gregf-2016-02-03_09:19:17-fs-greg-fs-testing-23---basic-mira/4597/


Related issues

Duplicated by sepia - Bug #14644: "Could not resolve host: gitbuilder.ceph.com" in rados-jewel-distro-basic-smithi Duplicate 02/04/2016
Duplicated by sepia - Bug #15297: kernel yum install task failed due to apparent dns failure on gitbuilder.ceph.com Closed 03/28/2016

History

#1 Updated by Zack Cerza over 3 years ago

  • Priority changed from Urgent to High

I see 8 instances of this as of now:
http://sentry.ceph.com/sepia/teuthology/issues/44/

Dropping priority

#2 Updated by Zack Cerza over 3 years ago

  • Subject changed from failing gitbuilder connections from mira to failing gitbuilder connections from mira (DNS lookup errors)

#3 Updated by Yuri Weinstein over 3 years ago

  • Duplicated by Bug #14644: "Could not resolve host: gitbuilder.ceph.com" in rados-jewel-distro-basic-smithi added

#4 Updated by David Galloway over 3 years ago

  • Category changed from Gitbuilder to Infrastructure Service
  • Assignee set to David Galloway

#5 Updated by David Galloway over 3 years ago

  • Duplicated by Bug #15297: kernel yum install task failed due to apparent dns failure on gitbuilder.ceph.com added

#6 Updated by David Galloway about 3 years ago

  • Status changed from New to Resolved

We've moved to a new nameserver

Also available in: Atom PDF