Project

General

Profile

Bug #14575

daemons leave pid files behind in /home/ubuntu/cephtest

Added by Sage Weil about 7 years ago. Updated about 7 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2016-01-29T23:37:58.059 INFO:teuthology.orchestra.run.smithi059:Running: 'find /home/ubuntu/cephtest ls ; rmdir - /home/ubuntu/cephtest'
2016-01-29T23:37:58.130 INFO:teuthology.orchestra.run.smithi059.stdout:34865350 4 drwxr-xr-x 2 ubuntu ubuntu 4096 Jan 30 07:37 /home/ubuntu/cephtest
2016-01-29T23:37:58.130 INFO:teuthology.orchestra.run.smithi059.stdout:34866152 4 rw-r--r- 1 root root 5 Jan 30 07:36 /home/ubuntu/cephtest/osd.1.pid
2016-01-29T23:37:58.131 INFO:teuthology.orchestra.run.smithi059.stdout:34866151 4 rw-r--r- 1 root root 5 Jan 30 07:36 /home/ubuntu/cephtest/osd.0.pid
2016-01-29T23:37:58.131 INFO:teuthology.orchestra.run.smithi059.stdout:34865355 4 rw-r--r- 1 root root 5 Jan 30 07:36 /home/ubuntu/cephtest/mon.0.pid

on shutdown.

/a/sage-2016-01-29_14:30:26-rados-wip-sage-testing---basic-smithi/50696
/a/sage-2016-01-29_14:30:26-rados-wip-sage-testing---basic-smithi/50676

My guess is this is related to https://github.com/ceph/ceph/pull/7075/files


Related issues

Duplicates Ceph - Bug #13422: pid file that was deleted after ceph restart leads to osd process lose control Resolved 10/09/2015

History

#1 Updated by Kefu Chai about 7 years ago

  • Assignee set to Kefu Chai

#2 Updated by Loïc Dachary about 7 years ago

When running the ceph-disk suite, I get

2016-02-01 07:46:51.246137 7f86291b47c0  0 ceph version 10.0.2-1506-gf9ec332 (f9ec332b03b8f145dd47dc4140707c237a37a254), process ceph-osd, pid 29861
2016-02-01 07:46:51.246227 7f86291b47c0  5 object store type is filestore
2016-02-01 07:46:51.246798 7f86291b47c0  1 accepter.accepter.bind my_inst.addr is 0.0.0.0:6800/29861 need_addr=1
2016-02-01 07:46:51.246823 7f86291b47c0  1 accepter.accepter.bind my_inst.addr is 0.0.0.0:6801/29861 need_addr=1
2016-02-01 07:46:51.246838 7f86291b47c0  1 accepter.accepter.bind my_inst.addr is 0.0.0.0:6802/29861 need_addr=1
2016-02-01 07:46:51.246853 7f86291b47c0  1 accepter.accepter.bind my_inst.addr is 0.0.0.0:6803/29861 need_addr=1
2016-02-01 07:46:51.246861 7f86291b47c0 -1 write_pid_file: failed to open pid file 'osd.3.pid': (13) Permission denied

which is most probably a variant of this.

#3 Updated by Kefu Chai about 7 years ago

  • Assignee changed from Kefu Chai to Loïc Dachary

#4 Updated by Loïc Dachary about 7 years ago

  • Status changed from New to Duplicate

Re-opened #13422 to help with backporting since fixing this problem is required for the 13422 backports to work properly.

#5 Updated by Loïc Dachary about 7 years ago

  • Duplicates Bug #13422: pid file that was deleted after ceph restart leads to osd process lose control added

Also available in: Atom PDF