Project

General

Profile

Bug #1453

osd: warn on object_info_t::size != st_size when building scrub_map

Added by Sage Weil over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I belive that #1376 is caused by an st_size != object_info_t::size mismatch (from some bugs a few versions back). Scrub should notice this (and ideally repair it).

Probably need a second size field in ScrubMap::object for the ondisk (or oi) size?


Related issues

Related to Ceph - Bug #1376: errant scrub stat mismatch logs after upgrade Resolved 08/08/2011

History

#1 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_position set to 46

#2 Updated by Josh Durgin over 9 years ago

  • Status changed from New to In Progress
  • Assignee set to Josh Durgin

#3 Updated by Josh Durgin over 9 years ago

  • Status changed from In Progress to Resolved

This is detected by scrub now, but repairing it will take more work, since the scrub system isn't designed to repair intra-node inconsistencies right now (#1474).

Also available in: Atom PDF